Error when trying to update - bad keys message

Hello all, I finally got some time to look into why my new switches weren’t working, and I was on 3.0.1, so way back on versions, and I read another forum post where a guy had my same switches that needed a newer zwave binding for the database so the switches could function.

I couldn’t find any simple way to update from 3.0.1 to latest stable 3.4.2 (as of today). I tried following the directions here for the manual install upgrade update commands. openHAB on Linux | openHAB

After running the update command I get key errors. I’ve searched these errors and found several threads on updating the key commands, and still doesn’t work:

[20:50:16] openhabian@openHABianDevice:~$ sudo apt-get update
Get:1 comitup InRelease [4,659 B]
Hit:2 stable InRelease
Hit:3 buster InRelease
Hit:4 buster InRelease
Hit:5 buster InRelease
Hit:6 stable InRelease
Err:1 comitup InRelease
  The following signatures couldn't be verified because the public key is not available: NO_PUBKEY 0959C4A3DCF89FBF
Reading package lists... Done
W: An error occurred during the signature verification. The repository is not updated and the previous index files will be used. GPG error: comitup InRelease: The following signatures couldn't be verified because the public key is not available: NO_PUBKEY 0959C4A3DCF89FBF
W: Failed to fetch  The following signatures couldn't be verified because the public key is not available: NO_PUBKEY 0959C4A3DCF89FBF
W: Some index files failed to download. They have been ignored, or old ones used instead.
  • Platform information: RaspPi

If you are on openHABian, you could have simply run openhabian-config and upgrade from there. Now that you’ve done some mucking about I couldn’t say if that will still work or not but it’s work a try.

The problem seems to be with the comitup repo which isn’t openHAB so things should be ok on that point. And perhaps openhabian-config can repair the broken repo too. I’ve no idea what that repo does.

In a pinch, you could simply remove it from /etc/apt/ and it will stop trying to look for updates on that package. of course it won’t update package any more either.

Have you tried instructions as described under Using the comitup repository ?
There is a link to download the latest deb package to install a gpg key.

openhabian-config installs the comitup package which on homepage is described as

Wifi Network Bootstrap for the Raspberry Pi

Comitup is a software package that provides a service to establish Wifi networking on a headless computer (that is, one with no video, keyboard, or mouse). Comitup supports the following capabilities:

The comitup service, which automatically connects to any previously established Wifi Access Points, if possible. Otherwise, it will create a stand-alone Access Point with the name (SSID) ‘comitup-<nnn>’, where ‘<nnn>’ is a unique, persistent number.
Defined ZeroConf mdns address name for ‘comitup-<nnn>.local’, advertising the IP address of the Raspbery Pi on all interfaces.
Connection information is published as a _comitup._tcp service, visible using a ZeroConf Browser.
A comitup-web service, which provides a web interface for selecting and authenticating against an existing Access Point.
A captive portal, facilitating discovery of the web service on systems that support it.</li>
The portal also features a “Locate” function that will blink the front green LED on a a Raspberry Pi, allowing the user to discriminate between multiple Comitup Pi’s.
If two wifi interfaces are available on the device, the comitup hotspot will remain on one, and the other will be used for the upstream connection. Routing/masquerading between the two networks is established automatically.
A comitup-cli command-line utility for interacting with comitup.

Ill try that command. After rebooting from the failed command, openhab (panel) still functions properly and controls my devices. I did a backup also just in case, so hopefully it backed up everything because i had 70+ devices and would like not to have to add everything again.