Errors after update to 1530

Tags: #<Tag:0x00007efeda66dc00> #<Tag:0x00007efeda66db38> #<Tag:0x00007efeda66da70>

i haven’t updated snapshot for about 2 months until today, now I’m getting errors. Does this look familiar to anyone?

1507 semed to run like a charm

now this is
Version: 2.5.0-SNAPSHOT (#1530)

User: openhab (Active Process 23307)
User Groups: openhab tty dialout audio bluetooth gpio

Directories: Folder Name | Path | User:Group
----------- | ---- | ----------
OPENHAB_HOME | /usr/share/openhab2 | openhab:openhab
OPENHAB_RUNTIME | /usr/share/openhab2/runtime | openhab:openhab
OPENHAB_USERDATA | /var/lib/openhab2 | openhab:openhabian
OPENHAB_CONF | /etc/openhab2 | openhab:openhabian
OPENHAB_LOGDIR | /var/log/openhab2 | openhab:openhabian

URLs: http://192.168.178.31:8080
https://192.168.178.31:8443

i updated via apt-get , also tried to completely reinstall, then imported my backup and the errors happened again.also tried clearing cache, nada.

2019-02-22 14:36:21.437 [ERROR] [core.karaf.internal.FeatureInstaller] - Failed installing ‘openhab-persistence-mapdb, openhab-binding-hyperion, openhab-
misc-openhabcloud, openhab-binding-tplinksmarthome, openhab-transformation-javascript, openhab-binding-network, openhab-persistence-influxdb, openhab-ui-
habpanel, openhab-misc-ruleengine, openhab-transformation-jsonpath, openhab-binding-mqtt1, openhab-binding-mqtt, openhab-ui-basic, openhab-transformation
-map, openhab-action-mail, openhab-binding-logreader, openhab-binding-fritzboxtr0641, openhab-binding-astro, openhab-transformation-xslt, openhab-binding
-homematic, openhab-binding-systeminfo, openhab-ui-paper, openhab-binding-wol1’: Unable to resolve root: missing requirement [root] osgi.identity; osgi.i
dentity=openhab-ui-basic; type=karaf.feature; version="[2.5.0.SNAPSHOT,2.5.0.SNAPSHOT]"; filter:="(&(osgi.identity=openhab-ui-basic)(type=karaf.feature)(
version>=2.5.0.SNAPSHOT)(version<=2.5.0.SNAPSHOT))" [caused by: Unable to resolve openhab-ui-basic/2.5.0.SNAPSHOT: missing requirement [openhab-ui-basic/
2.5.0.SNAPSHOT] osgi.identity; osgi.identity=org.openhab.ui.basic; type=osgi.bundle; version="[2.5.0.201902220725,2.5.0.201902220725]"; resolution:=manda
tory [caused by: Unable to resolve org.openhab.ui.basic/2.5.0.201902220725: missing requirement [org.openhab.ui.basic/2.5.0.201902220725] osgi.wiring.pac
kage; filter:="(osgi.wiring.package=org.openhab.ui.dashboard)"]]

Hi, I have the same problem.
The snapshot is not working yet. See here:

So at the moment you can do a downgrade or restore backup.
BR Sebastian

1 Like

What will probably also fix it is executing:

feature:install openhab-ui-dashboard

in the Karaf Console.

1 Like

Oh thanks. the usual snapshot breakage then :expressionless:

I thought it was my fault because i tried to go back a bunch of revisions in the apt repo but the errors persisted