Eurotronic Spirit Thermostatic Valve (TRV)


I have several of these devices working OK under openHAB. I just tried to install a new one but it is registering as an ‘Unknown device’.
I excluded one of the existing TRVs and tried re-including it - that shows the same behaviour.
Has something been edited in the Database? The only mention of ‘spirit’ in the log is against Aeotec who re-badge the Eurotronic Spirit. Has the Eurotronic entry been accidentally deleted maybe?
I’m running openHAB 2.5.11 but I’m about to upgrade to 3.0, so if it’s been fixed in that I’m OK.

Log (debug) of the interaction when I try to re-initialise the device (I have tried this several times) is too big too paste here, however the pertinent entry appears to be this:

2021-01-05 15:34:19.960 [DEBUG] [ding.zwave.handler.ZWaveThingHandler] - NODE 33: Unable to find thing type (0148:0003:0001:0.16)

Use the installation script to manually install the snapshot binding. There was a database issue with that device that has been resolved

Thanks for the info. Do you know if the related database issue has been fixed in any 3.x versions? I was planning to upgrade to 3.0 soon anyway.

For 3.0 you also need the snapshot

I THINK the script works with 3.0 too. It is here & the manual installation instructions are in the README.

Zigbee and Z-Wave manual install script - Tutorials & Examples - openHAB Community

Ok thanks. There was already a post at the end of the manual install script thread asking the question a few days ago but no reply yet - I have just bumped it.

The author is taking a break but he thought it would work

OK - looking at my notes I think I did it manually last time anyway - it was fairly straightforward.

1 Like

Just put the jar in the addons folder after uninstalling the old binding.
Then delete the Thing from OH & re-discover to get the new settings.