Eurotronics Spirit Value Controller Z-Wave plus Disable Buttons

Tags: #<Tag:0x00007f5ca1271078>

Hi,

according the manual the Spirit zwave value controller support enable/disable the local buttons ofer the air (sorry I found only the german manual):

6.7      Kindersicherung      Die Kindersicherung des Spirit Z-Wave Plus kann per Funk gesetzt oder entfernt werden. 
Schutzzustand           Beschreibung
0x00                    Ungeschützt Bedienung uneingeschränkt möglich
0x01                    Beschränkt: Bedienung nicht möglich. Gerät muss zunächst entsperrt werden
0x02                    Deaktiviert: Bedienung vollständig deaktiviert. Gerät kann nur per Funk gesteuert werden.

How can I use this? I can’t find any item like “child protection” or “lock buttons”.

– Tolotos

Do you have an electronic copy of the manual? That feature may have been added with a firmware update.

The channel for the protection command class is missing in the database, I’ve added it.
You need to update to a recent zwave snapshot binding.

2 Likes

This means if I update to 2.5RC1 the channel is available?

You likely will need to wait for 2,5 stable to be released tomorrow if @sihui just made the change a while ago.

I don’t think it will be in 2.5 RELEASE either. You will need to wait for the first 2.6 SNAPSHOT.

@sihui what device did you change? The only change I see around this time that looks related is to the Cooper RF9540 wallswitch, but I don’t think that’s the device being discussed is it?

I thought Kai stated 3.0 was next. I found that surprising.

I’m not sure - but whatever the next milestone is, it will be there.

My guess is that there will be another 2.x - either 2.6, or 2.5.x

1 Like

https://eurotronic.org/wp-content/uploads/2018/08/Spirit_Z-Wave_BAL_web_DE_view_V5.pdf

I added the protection_local channel to

https://www.cd-jackson.com/index.php/zwave/zwave-device-database/zwave-device-list/devicesummary/710

When I do database changes the timestamp is already 1 hour behind. Some Daylight Saving Time issue?

The times in the history were correct based on the times I received the emails. But even then, it doesn’t show in the log at all - the only one that shows around this time for you is this cooper device and the time is just a few minutes before you sent the message here to say you’d updated it… (database logs 14:54 and your message above saying your added it was at 14:56). The email I got at that time was also for the Cooper device…

If I look at the database for this device, it’s not changed for nearly a month. This is consistent with Github which also shows no changes for a month.

I guess it doesn’t matter, but it’s a bit strange as it definitely points to you adding it to the cooper device, not the spirit. I thought it might be some sort of issue with the history logging, but I don’t really think that explains it either.

:confused:

I have no idea what happened, sorry. I guess I need to make the edits to the database when I have more spare time and not, like yesterday, “in between in a hurry”. :sunglasses:

1 Like

One of my Spirits has locked itself … I let it deplete the battery to 0% and when I changed it the child lock appeared. I am unable to turn it off by pressing + and - for 3 seconds, as stated in the manual. So I presume it is locked with this mode (0x02) that I cannot change without a channel.
I’m running openhab 2.5.4, I guess its stable. I tried removing and adding the thing and I got one new channel (Basic deprecated), but no protection channel.
I have 7 Spirit valves and I could try removing them all and uninstalling zwave bind, as I didn’t do this since the original install about 1.5 years ago. But I would like to know if this will solve the issue beforehand, or do I have to get some beta binding to get this channel.
Ideally I would like to also upgrade to working Basic channel for setting MANUAL mode (type31 for direct valve control) from this topic, that also doesn’t seem like it’s working yet: Eurotronic Spirit - Unsupported mode type 31

Please advise.

BTW, here is the link to the English manual for the Spirit:

Thanks and best regards!

The protection channel problem in my case was actually already solved by removing and adding a thing. As I wrote above, I got new Basic channel, and also “Local Device Protection”, but it was hidden, available only after pressing more button on the right of channels. So that was my bad that I didn’t notice it.
Refreshing things channels works as it should in my configuration.
I’m still on my toes for the manual mode solution though.
BR

1 Like

It’s “Manual Mode” in the mode popup - you looked there?

I don’t recall the details, but I tried some things and couldn’t get valve mode to work when I’ve updated from 2.4.x to 2.5.x. As I had not much set up, I’ve made a clean install of 2.5.x, that worked.

You can try to remove the XML file in the zwave folder, I believe for some that worked.

Thanks for you hint regarding Device Protection - i lost THAT one, and loosed a lot of time, just because I didn’t notice the “More” button… :crazy_face: Shiny UIs have their disadvanteges… And people without glasses. :grin: