Everspring AD142 without any channel

Hi folks!

I’m starting with OpenHab2 and ZWave, When including a Everspring AD142 dimmer, it’s not showing any channel. I’ve read the basic documentation and tried to find a solution online before posting here. :slight_smile:

My current Configuration:

Steps that I’ve done so far:

  • OpenHab 2.3 installation and initial configurations
  • Installed some UI Add-ons (REST API, CLASSIC UI, PAPER UI, BASIC UI, HABMIN, HABPANEL)
  • Installed Z-Wave Binding Add-On
  • Added a Z-Wave Serial Controller (as a Thing). It’s showing as online with 5 channels, so I think it’s working fine.
  • Included AD142 Dimmer Plug (as a Thing). It’s showing as online, I can see it’s properties, I can’t see any channel.

Any ideas on what I might be doing wrong?

Leone Cesca

What exactly is shown in the UI? What are the properties shown? Can you provide a couple of screenshots?

Sure, here it is. Let me know if you need anything else!

Thanks. All looks fine - I’m afraid I’m not sure why it would show no channels. The database looks fine, so I don’t see any issue with the definition. I would check to see if there are any errors in the logs - I think in general once the thing type is set, then the channels should be displayed without any input from the binding (ie the system does all this based on the XML file, which looks ok).

I guess one thing to check is that the thing type is correct - this is shown in the things list. I expect it is, otherwise you probably wouldn’t see the name etc that is shown in the above image.

I’ve tried the following:

  1. Removed the node from the z-wave controller.
  2. Removed the node from Thing list
  3. Stopped the OpenHab2 service, deleted the logs, and started again.
  4. Added the node back to the z-wave controller (now as Node 2). No channels appeared yet.
  5. Using HABmin → Configuration → Things → Node 2, I’ve enabled the Advanced Settings on tools and tried a command (“Heal the device”). Got a red alert on the screen and the following error on log:
2018-06-12 13:42:52.559 [ERROR] [st.core.internal.thing.ThingResource] - Exception during HTTP PUT request for update config at 'things/zwave:device:5b5d4565:node2/config'
java.lang.NullPointerException: null
	at org.eclipse.smarthome.config.xml.AbstractXmlBasedProvider.get(AbstractXmlBasedProvider.java:151) [108:org.eclipse.smarthome.config.xml:0.10.0.b1]
	at org.eclipse.smarthome.config.xml.AbstractXmlConfigDescriptionProvider.getConfigDescription(AbstractXmlConfigDescriptionProvider.java:50) [108:org.eclipse.smarthome.config.xml:0.10.0.b1]
	at org.eclipse.smarthome.config.core.ConfigDescriptionRegistry.getConfigDescription(ConfigDescriptionRegistry.java:152) [103:org.eclipse.smarthome.config.core:0.10.0.b1]
	at org.eclipse.smarthome.config.core.ConfigDescriptionRegistry.getConfigDescription(ConfigDescriptionRegistry.java:188) [103:org.eclipse.smarthome.config.core:0.10.0.b1]
	at org.eclipse.smarthome.io.rest.core.internal.thing.ThingResource.normalizeConfiguration(ThingResource.java:735) [126:org.eclipse.smarthome.io.rest.core:0.10.0.b1]
	at org.eclipse.smarthome.io.rest.core.internal.thing.ThingResource.updateConfiguration(ThingResource.java:415) [126:org.eclipse.smarthome.io.rest.core:0.10.0.b1]
	at sun.reflect.NativeMethodAccessorImpl.invoke0(Native Method) ~[?:?]
	at sun.reflect.NativeMethodAccessorImpl.invoke(Unknown Source) ~[?:?]
	at sun.reflect.DelegatingMethodAccessorImpl.invoke(Unknown Source) ~[?:?]
	at java.lang.reflect.Method.invoke(Unknown Source) ~[?:?]

I was able to setup a PineA64 with OpenHab2 on it, and successfully recognized the switch/dimmer.

I am suspecting of Java version (that is Oracle Java 8 on my Windows 7). Will try to migrate it to OpenJDK 8 as recommended and will post the results here.

Thanks Chriss Jackson for the quick responses on this post, Really appreciated it.

Tried with the following java version and didn’t work as well:
openjdk version “1.8.0_112”
OpenJDK Runtime Environment (Zulu 8.19.0.1-win64) (build 1.8.0_112-b16)
OpenJDK 64-Bit Server VM (Zulu 8.19.0.1-win64) (build 25.112-b16, mixed mode)

Any recommendations? It’s working with Pine A64.