Ewelink / Sonoff Binding - New binding without flashing

Tags: #<Tag:0x00007fc90f673790> #<Tag:0x00007fc90f673650> #<Tag:0x00007fc90f673560>

could you send me the debug log please. not sure…

Ok, i have read about logging (Logging | openHAB) so i have found the events.log and the openhab.log.

But i didn´t find a debug log. i startet log:tail. if i want to set the level to debug i have to give the console the packaged-subpackage but i didnt find it - so i guess this is because it gets an error befor it is acutally a binding on my system.

so perhaps can you explain me, what debug log do you want to have? as i said before i actually a beginner - so please apologize :slight_smile:

When you remove/readd binding, check the openhab.log just after. It should show what’s going on (will be at bottom).

ok, this is creepy.

Now there is nothing in the log. like the system is ignoring the jar file.

just to be sure - i have to put the jar file from above (download it from the top of this page) in /usr/share/openhab/addons and then i have to wait and look in the log.

i tried to restart the whole server, also to start stop the service. nothing happens - there is no binding and also no entry in the log…

I’m a little lost as to how openhab knows where the jar came from… there should be no references to GitHub from openhab.

How have you added the jar? Where have you put it…

It’s like openhab is trying to download the jar from GitHub - like a symlink.

You should be manually downloading the jar file only (nothing else).
Moving it from your download folder to:
openhab\addons

just to try it out i have deleted the working binding (homeconnect) that i installed yesterday, stopped the service, clear the cache and started the service. after that i tried to installed the binding like i did it yesterday, but it dont worked either.

so i think its a problem of my openhab. dont know why this want work anymore.

yes, i manually download the jar file and moved it into the folder. doesnt know how i could repair this - we will see. :slight_smile:

I’d create a post with the things you know so far and you should get a response from one of the main developers. I don’t know enough about the core to advise here, sorry.

i know that this isnt the right place here - i will do it from the start again. i think this will cost less time :slight_smile: but then i will come back an retry it :slight_smile:

Just something to note, region I have set as GB and IP address is my local openhab address and port, is this right ?

its a lack of error checking at the moment… which i am doing as we speak, what’s your account config as it seems to be failing the login? (without user/pass)

region = eu :slight_smile:
ip address without port

Thanks, now showing as online. Will try to add my things and revert.

Hi Dave, It has found a number of things, not all of which are on ewelink I dont think. Is there anyway of telling which relates to which device, i.e. can I see the mac address of the thing on openhab ?

The inbox should show the name of the device that is set in the Ewelink app, otherwise, when you add them from the inbox you can then go to the thing and look at the properties and it will tell you more detailed info.

If there is anything that is not discovered then send me the discovery response (that one json) from the logs and ill get them added. (hash out username / password)

what devices do you have?
are they listed on the top post as supported?
if not send me the line from the debug log and ill add them.

Now binding works. Seems it was corrupted during download, but reinstall solves this.

:blush:debug log ? There is nothing of note in the tail logs ?

you need to go on console…

log:set debug org.openhab.binding.sonoff

then remove the binding. Wait 30 seconds. Add the binding.
Now check the logs.

before the websocket connects there will be an entry “Discovery Response:”
I need what follows the colon (with user / pass hashed out)

remove the binding and then re-add, or from the ui start a discovery scan

You have added the account thing yes? Otherwise it definitely wont work.

Yes, the account think is online
From connection check, dont think this will help either

2021-02-03 17:27:11.439 [DEBUG] [noff.internal.handler.AccountHandler] - Sonoff - Connection check Running

2021-02-03 17:27:11.440 [DEBUG] [noff.internal.handler.AccountHandler] - Sonoff - Starting Cloud Connection

2021-02-03 17:27:11.499 [DEBUG] [ding.sonoff.internal.connections.Api] - Get WebSocket Server Response Raw:{“port”:8080,“IP”:“35.157.208.224”,“reason”:“ok”,“domain”:“eu-pconnect2.coolkit.cc”,“error”:0}

2021-02-03 17:27:21.700 [DEBUG] [onoff.internal.connections.Websocket] - Sonoff - WebSocket Socket org.openhab.binding.sonoff.internal.connections.Websocket@6ea7e0ad successfully connected to eu-pconnect2.coolkit.cc/35.157.208.224

2021-02-03 17:27:21.702 [DEBUG] [onoff.internal.connections.Websocket] - Sonoff - login json: {“action”:“userOnline”,“at”:“ecd8b1176d92ee263e51e991f340755345b51a4c”,“apikey”:“4e09366d-bbeb-48a2-884c-a8c8fb285304”,“appid”:“oeVkj2lYFGnJu5XUtWisfW4utiN4u9Mq”,“nonce”:“eBOXKEHM”,“ts”:1612373241,“userAgent”:“app”,“sequence”:1612373241701,“version”:8}

2021-02-03 17:27:21.805 [DEBUG] [onoff.internal.connections.Websocket] - Sonoff - Websocket Message recieved: {“error”:0,“apikey”:“4e09366d-bbeb-48a2-884c-a8c8fb285304”,“config”:{“hb”:1,“hbInterval”:145},“sequence”:“1612373241701”}

2021-02-03 17:27:21.807 [DEBUG] [noff.internal.handler.AccountHandler] - Sonoff - Websocket Connected: true

2021-02-03 17:28:11.501 [DEBUG] [noff.internal.handler.AccountHandler] - Sonoff - Connection check Running

2021-02-03 17:28:48.210 [DEBUG] [noff.internal.handler.AccountHandler] - Sonoff - Websocket Connected: false

2021-02-03 17:28:48.213 [DEBUG] [noff.internal.handler.AccountHandler] - Sonoff - Websocket Connected: false

2021-02-03 17:29:11.503 [DEBUG] [noff.internal.handler.AccountHandler] - Sonoff - Connection check Running

2021-02-03 17:29:11.505 [DEBUG] [noff.internal.handler.AccountHandler] - Sonoff - Starting Cloud Connection

2021-02-03 17:29:11.539 [DEBUG] [ding.sonoff.internal.connections.Api] - Get WebSocket Server Response Raw:{“port”:8080,“IP”:“3.120.166.65”,“reason”:“ok”,“domain”:“eu-pconnect7.coolkit.cc”,“error”:0}

2021-02-03 17:29:12.302 [DEBUG] [onoff.internal.connections.Websocket] - Sonoff - WebSocket Socket org.openhab.binding.sonoff.internal.connections.Websocket@6ea7e0ad successfully connected to eu-pconnect7.coolkit.cc/3.120.166.65

2021-02-03 17:29:12.306 [DEBUG] [onoff.internal.connections.Websocket] - Sonoff - login json: {“action”:“userOnline”,“at”:“ecd8b1176d92ee263e51e991f340755345b51a4c”,“apikey”:“4e09366d-bbeb-48a2-884c-a8c8fb285304”,“appid”:“oeVkj2lYFGnJu5XUtWisfW4utiN4u9Mq”,“nonce”:“WDrFXXyk”,“ts”:1612373352,“userAgent”:“app”,“sequence”:1612373352306,“version”:8}

2021-02-03 17:29:12.410 [DEBUG] [onoff.internal.connections.Websocket] - Sonoff - Websocket Message recieved: {“error”:0,“apikey”:“4e09366d-bbeb-48a2-884c-a8c8fb285304”,“config”:{“hb”:1,“hbInterval”:145},“sequence”:“1612373352306”}

2021-02-03 17:29:12.412 [DEBUG] [noff.internal.handler.AccountHandler] - Sonoff - Websocket Connected: true

2021-02-03 17:30:11.541 [DEBUG] [noff.internal.handler.AccountHandler] - Sonoff - Connection check Running

1 Like