Example for zwave thing and item

can someone give me a example of adding a zwave thing and device via .things and .items file?

For the begining (I want to switch from homee to openHAB2) I want to include a Aeon Labs RangeExtender 6 (ZW117) to learn how to add things and items manually via textfiles.

Discovery with PaperUI shows me “zwave:device:9be826b1:node4”
The supported things website gives me

  • UID “aeon_zw117_00_000”
  • channels “switch_dimmer, color_color, color_temperature”

Note the this is only available in the latest binding (ie 2.4 M4 or newer).

From this I added

Thing zwave:aeon_zw117_00_000:controller:node4 "Aeon Repeater" (zwave:serial_zstick:controller) [ nodeid=4 ]

But I get still errors:

'zwave:aeon_zw117_00_000:controller:node4' changed from UNINITIALIZED to UNINITIALIZED (BRIDGE_UNINITIALIZED)

How can I find the bridge parameters?

Have you tried reading the documentation? What are you missing specifically?

Yes I read the documentation but maybe my english knowledge is to bad to understand.

I added this into a file z-wave.things

Bridge zwave:serial_zstick:controller "ZWave Controller" [ 
        port="/dev/ttyAMA0",   <== value from PaperUI
        //heal_time="<possible values ?>",
        //inclusion_mode="<possible values ?", 
        //controller_wakeupperiod="<usefull values ?>",                                                            
        security_networkkey="<value from PaperUI ZWAVE controller view>" ] 
    // Add things here

But PaperUI shows the controller as offline.

Edit: I found /dev/ACM0 using Google search and tried this value. Now the controll is displayed as online.

EDIT2: Parameters soft and hard reset are not used?! I found them here in the forum. How can I reset the controller to start with empty nodes?

Ok, this must be one reason. I have binding 2.3.0.
Does this mean I must switch to a dev branch?

Edit: I updated to “testing (2.4…)” and now I have the thing working. Next I start testing the items.

Edit2: items are working too