Exception caught while starting SSH server; java.net.SocketException: Operation not permitted

I am getting

2020-10-10 09:14:49.366 [WARN ] [org.apache.karaf.shell.ssh.Activator] - Exception caught while starting SSH server
java.net.SocketException: Operation not permitted
at sun.nio.ch.Net.listen(Native Method) ~[?:1.8.0_265]
at sun.nio.ch.AsynchronousServerSocketChannelImpl.bind(AsynchronousServerSocketChannelImpl.java:163) ~[?:1.8.0_265]

on my Raspberry on which I installed the Openhab snap today. At first I was getting address already in use on port 8080. After resolving that now I am getting this. I am not getting any specific port information in the logs.

Kindly help me out.

openHAB use ssh port 8101.
This is configured in file /var/lib/openhab2/etc/org.apache.karaf.shell.cfg.
Search for this entry:

sshPort = 8101

Thanks for your response. Yes I found that file and tried changing the port and restarting but I am still getting the same error. Also, the error is different from the ‘address already in use’ which would have hinted to a port already in use issue.

However in my case, I am getting operation not permitted error. Ring any bells?

How did you install the software ( via openhabian-config or via repository installation ) ?
The startup is done by using systemctl command resp. reboot ?

I used this command.

sudo snap install openhab

Resolved after instaling openhab via apt.

This topic was automatically closed 41 days after the last reply. New replies are no longer allowed.