Expiration timer sometimes fails

OH3.1.0M3 running on centos 8.

I’ve set up an expiration timer on a bathroom fan switch. When it’s set to say 5 seconds it works just fine. I reconfigure it for two hours which is what I want eventually and the fan never turns off. The toggle switch isn’t getting activated by hand, the OH software isn’t being restarted and the system isn’t getting rebooted.

Added: I’m not seeing any state changes in the log beyond the actual physical toggle switching that is being done.

I tried changing the code to 7200 seconds and the fan is still on after five and a half hours.

I’ve tried setting:

7200 seconds

None worked

I’ve successfully tried:

5 seconds
10 seconds
1 minute
1 minute, 10 seconds
5 minutes

What’s the trick to getting a two hour timer working to send an off command?

A wild guess. Do you use persistence?
Could it be that ‘something’ is updating your timer items?
Have a look in the /var/log/openhab/events.log

Depending on the device technology, periodic routine updates may be sent. Updates to same state are not shown in logs.

@BiloxiGeek are you using the Expire binding?

Yes, I’m defining the timer in the expiration metadata.

The switch is z-wave, GE 14292 in-wall toggle switch.

Permanently powered zwave device make periodic status reports. You won’t be able to use a long ‘expire’ directly, because the periodic update restarts the timing.

More from the guru :slight_smile:

Okay, resurrected my old 2.5 timer into a rules file. Seems to be working as expected.


There is no expire binding in OH3. It is part of the core functionality.

This topic was automatically closed 41 days after the last reply. New replies are no longer allowed.