Expire Times great than 2 minutes not working


I have openhab2.1, on a rasp. pi and I’m very happy with it.

I’ve have configured everything with the PaperUI, apart from items which I want to be visible to HomeKit and Alexa

However, I’m having trouble with the expire binding. It works well for any time less than 2 minutes, but fails for anything more than that.

What I’ve tried so far is:

Added the expire option at the end of my homekit.items:

Switch Study_Heater “Study Heater” (gStudy) [ “Switchable” ] { expire=“2m,command=OFF” }

Works fine for small number, but nothing over 2 minutes.

  1. I read this:

If another binding is repeatedly updating the state of the item to be the same state it already was, the expiration timer will continue to be reset into the future. Dedicating an item to the expiration function (so it doesn’t receive repeated updates from another binding) would avoid unwanted behavior, should it apply in your case.

So I created another item in homekit.items, so it now looked like this:

Switch Study_Heater “Study Heater” (gStudy) [ “Switchable” ]
Switch Study_Heater_Expire “Study Heater (Expire)” { expire=“2m,command=OFF” }

I Linked them both of the same Thing and it didn’t really help; short expire times worked, longer ones didn’t.

Any suggestion on what I should try next?

Thank you.


Just to follow up:

I’m trying to control a WeMo, and I see nothing obvious in the log files.

That’s the problem. Your Item will get all the updates through the thing. If other bindings doing updates to the item, the expire binding will retrigger. o the only way is, to decouple these two items completely and do a “one-way sync” through a rule.

Thank you.

Is there a way to determine what the bindings are doing updates? I don’t see anything in any logs?



You can’t see what bindings are updating the Item but you can see that the Item is being updated by looking in the events.log. It doesn’t really matter what binding is doing the updating. If your Item receiving an update every two minutes or less the Expire binding will never trigger.


Thank you.

That’s very interesting, I don’t see any events in the events log that would restart the expiration timer.

I suspect my issue is caused by something else.

Is there a debug/trace for the expire binding?

Thanks again

There should be like any other binding. There must be something going on. I’ve use Expire since it was released and all of my times are longer than 2 minutes.


It turns out I had a few issues:

  1. I had copied and pasted the settings and some not-standard characters got included.
  2. Editing the items file caused homekit to reloads the items and reset the expire timer.
  3. I had intermittent power problems due to a storm, causing a quick power cycle.

Thank you for all you help.