Failed installation on Pi3B+ - Cloning myself... FAILED

Tags: #<Tag:0x00007faee5ca7100>

I’m having the same problem over and over again trying to install OpenHABian on my newly purchased Pi3B+:

login as: openhabian
openhabian@10.20.201.108's password:
Linux openHABianPi 4.9.80-v7+ #1098 SMP Fri Mar 9 19:11:42 GMT 2018 armv7l

The programs included with the Debian GNU/Linux system are free software;
the exact distribution terms for each program are described in the
individual files in /usr/share/doc/*/copyright.

Debian GNU/Linux comes with ABSOLUTELY NO WARRANTY, to the extent
permitted by applicable law.

Wi-Fi is disabled because the country is not set.
Use raspi-config to set the country before use.
Every 2.0s: cat /boot/first-boot.log                                                              openHABianPi: Tue Mar 13 22:59:31 2018

2018-03-13_22:53:40_UTC [openHABian] Starting the openHABian initial setup.
2018-03-13_22:53:40_UTC [openHABian] Storing configuration... OK
2018-03-13_22:53:40_UTC [openHABian] Changing default username and password... OK
2018-03-13_22:53:41_UTC [openHABian] Setting up Ethernet connection... OK
2018-03-13_22:53:41_UTC [openHABian] Ensuring network connectivity... OK
2018-03-13_22:53:41_UTC [openHABian] Waiting for dpkg/apt to get ready... OK
2018-03-13_22:53:54_UTC [openHABian] Updating repositories and upgrading installed packages... OK
2018-03-13_22:56:08_UTC [openHABian] Installing git package... OK
2018-03-13_22:56:36_UTC [openHABian] Cloning myself... FAILED
2018-03-13_22:56:37_UTC [openHABian] Initial setup exiting with an error!

Can’t get past initial setup it seems :confused:
I have downloaded latest release: https://github.com/openhab/openhabian/releases
I have tried writing img using both Etcher and Win32DiskImager.
I have tried different SD-cards, 32GB and 64GB.
I have tried different powersupplies, chargers and cables.

Any help appreciated.

Cheers,
André

I don’t have a solution but I added the openhabian tag so hopefully others will see it and be able to help.

Is the Pi able to connect to the internet? This is the line that is failing.

/usr/bin/git clone -b master https://github.com/openhab/openhabian.git /opt/openhabian &>/dev/null

Well, It’s on my work network and I can access the Pi from different computers, hence I’m taking it for granted. But it could be a possibility our firewall won’t let external traffic through. Anyway I can check if the Pi has internet access?

Cheers

sudo ping github.com
sudo traceroute github.com

I had the same error. In my case the ping worked, so I just ran the script again:
sudo /boot/first-boot.sh

Use user/pass: openhabian/openhabian (this is also root password)

and it worked the second time. Hope that helps others!

Has anyone come up with a solution to this yet? I am having the same issue. Cloning myself failed. Have tried 2 different Pi 3 B+ boards, 2 different SD cards as well as 2 different brands of imaging software. When it gets to the point of clone failure I get the login. When I log in with openhabian/openhabian it flashes and goes to a screen where I can do nothing. The cursor is in the bottom right corner instead of the left and I cannot type or anything. I have watched the power light and it does not flicker so I don’t believe it is a power supply issue either. I am able to put Raspbian on it and that works fine, but I want OpenHAB to work.

I don’t think you can diagnose power supply problems by watching for a flickering light. The RPi is very sensitive. It will fail long before the led dims a noticeable amount.

Since you can put Raspbian on there without problem, use the Manual installation instructions for openHABian. openHABian is just a bunch of scripts to install and configure OH and related services. You don’t have to use the SD image.

For anyone else who finds the process stopping at this line, I couldn’t continue by running first-boot.sh until I had deleted the /opt/openhabian contents.

When running
/usr/bin/git clone -b master https://github.com/openhab/openhabian.git /opt/openhabian
I got the following error
fatal: destination path '/opt/openhabian' already exists and is not an empty directory.

6 Likes

That worked for me! I guess it happened if your first attempt(s) failed and the directory has been populated. I wonder why all standard error in the script is redirected to /dev/null . It makes it more difficult to troubleshoot when something fails…

Hi. I had the same error. I solved it by adding a bypass rule to SSL Decryption in the firewall. As some of the repos use certificates the install will fail.

Just to say, had same issue. For anyone else banging their head against a wall, what worked for me was removing the /opt/openhabian contents AND directory:
sudo rm -R /opt/openhabian
then re-running the first boot script as has already been mentioned

I had the same issue but after removing the directory I rebooted and let the installation finish

Same issue here. I’ve followed steps described in this thread after having attached my Pi3B+ to a monitor and a keyboard:

  1. Checked internet connectivity: OK
  2. removed /opt/openhabian directory
  3. re-run /boot/first-boot.sh

Thanks all for very useful information. Much appreciated!!!

I guess there is a major problem with openhabian 1.4.1 still today.
I tried installation now about 10 times with 2 different SD Cards and 2 different Pi3b+

Always running into “Cloning myself” FAILED

What I noticed is that the installing process seems to work fine and finishes, but after a reboot the installation tries to start over again -> runnig into “Cloning mysql FAILED”. Anybody an idea whats going on?

So maybe - I guess - the installation may work fine but ist just not able to detect itself has successfull finished.

Had the same error, I tried all the solution mentioned earlier but nothing worked.
The solution for me was was deleting the content of /opt/openhabian as well.
Thanks a lot! :slight_smile:

New install on Raspberry Pi 1 and I also have to delete the contents of the /opt/openhabian directory to avoid the “cloning” failure. But it is now failing on the Log Viewer (frontail) install and I still can’t get through the initial setup. I am not sure how to get past this failure or get more details on why it is failing. Any help would be appreciated.

Long term you will find the RPi 1 wholly inadequate to run openHAB.

What do you see on the screen when installing Frontail fails?

It might work better for you to try the manual install which will get you started with a base installation that you can then put openHABian on top of.

Thanks, I will try the manual install. It just displays a line about installing the Log Viewer (frontail) and indicates that it failed - no details. Note that I can run Kodi fine on the RPi 1 so it seems that it should be powerful enough but I guess I will find out.

OH needs more RAM than the RPi 1 offers to run well. The minimum recommended RPi is the RPi 2.