Failed to get statvfs. Error code: 13

Hi Everyone!

After upgrading from 2.4 stable to 2.5 M2 I get the following error almost every 2 second:

Failed to get statvfs. Error code: 13

I have the Systeminfo binding installed, which might cause this, but why? I’m using openHABian on RPi 3B+ so I tried to fix permissions, reboot, restart, etc but none of them worked.

Any idea why this happens?

After removing the Systeminfo binding, the error is gone…

Does anyone know how to resolve this error without removing the Systeminfo binding? I am currently using this binding to monitor my raspi.

Thanks for any help.

There has been some work on systeminfo binding since 2.5M2

I would suggest trying out the snapshot version, and opening a new issue if your problem persists.

Basically, I just need to temporarly remove the storage related items. Any other channel work without errors

Hi Kristof,

thanks for your reply. I did some further analysis on this issue and the problem is a missing permission on the Linux file system and my NAS. Looking at the implementation of the OSHI github and using their test class helped finding the folder.

Anyway, it seems nothing has to be changed in the binding, but I would suggest to add some comment into the openhab Wiki. Assuming the ‘openhab’ user needs access to the file system folders when gathering the information, this may be important information for at least the Linux and Un*x users.

Thanks for your nice work,

1 Like

Thanks for your clarification! It also seemed that some permission error causing this, but I didn’t went this far, because I don’t really need this information in my system. However if you can tell which folders were not accessible by default by the openhab user, it can help me…

I get this error on my mounted file shares. The strange thing is that I’ve mounted 3 file shares with the same permissions and the errors only occur on 2 of those shares. Also the openhab user should have write access to all shares. Any idea what could cause this?