Failure to open KNX serial interface

  • Platform information:
    • Hardware: Raspberry Pi 4 Model B 2GB
    • openHAB version:3.2.0
  • KNX interface: MDT SCN-USBR.02 USB interface

Hello, I’m a beginner in all aspects of open HAB, including the hardware and LInux, but I’m studying hard :wink:
I’v managed to get openHab up and running on my Raspberry, but when trying to instal the KNX USB interface, I keep getting this message:
failure to open serial port /dev/ttyAMA0

In the config tool I tried option 35: move Bluetooth to mini UART to free the serial port
The result was approx. the same, but this time with this message:
resetting BCU failed (no acknowledge reply received)

I searched through the topics on this forum, but did not find a solution.
Can anybody help?

UPDATE 8/04/2022
Meanwhile, I tried also the other fixes suggested here Serial Port Configuration | openHAB

  • Adapt Java command line arguments to include
  • I checked and confirmed that openhab and openhabian are both member of the dialout group
    But this did not solve my problem.
    So I hope somebody could help.

its all about drivers now maybe have a look at

then try to install knxd to route the bus onto ip overall not all usb interfaces are linux compatible and i also had mixed results

sometimes usb interface show up as ttyACM0

now try to follow this tread aswell

Thank you for this reaction.
I had a look at the patch to which you refer, but I can’t figure out how/where/on what system or file to run it. Sorry, but I am a Linux and RaspberryPi beginner, so this is overwhelming, but I am prepared to delve into it.
As to your second suggestion, knxd was not installed, in accordance with the instructions for automated openhabian image installation. I have installed it now.
Should I choose Tunnel or Router? I guess tunnel
How do I find the network adress of the KNX/IP gateway?
And for the network address of the local host to be used to set up the connection to the KNX/IP gateway, I suppose it is the IP adress of the RaspberryPi?
Thanks in advance

Router mode. Loopback should work Now the thing is you will never get a step by step instruction on everything you also need to read about what you install use etc. Maybe post here what you did how you install knxd what happened after that configurations that you did. Simply saying i did this then it’s not working is not very helpful for me also others.

Thanks again for your reply.
Meanwhile, I also contacted the MDT support, and this is what they answered:

The UBS interface can only be used for programming the components via the ETS. If you want to access the system externally, there is the tunneling access or multicast access via the network. Tunneling access is supported by the IP interface and the IP router supports tunneling & multicast access.

So, I was misled by the name giving and the very sparse documentation of the MDT USB interface.

The conclusion is I’ll have to take a different approach now. This thread can be closed.