Fakro AMZ Z-Wave awning blind - device missing

I’m new to openhab world and even less experience w Zwave:)
Have managed so far few sonoff switches w OH2 tanks to great userr manuals and community articles.

Today installed Fakro AMZ Z-Wave awning blind. Had added aotec’s z-stick before and can see the blinds as “unknown devices”. As I understand (after few hours of unsuccessful items/sitemap config attempts;)), until I resolve this - to map the devices to an entry in device database - I won’t be able to control the blinds through OH.

I wonder, can anyone help with adding them to the db (probably very similar as the existing ARZ devices)?

Linking the node.xml and manufacturers user manual
https://dl.dropboxusercontent.com/u/19405245/node2.xml

Thank you so much!

cheers,
au

Done:
http://www.cd-jackson.com/index.php/zwave/zwave-device-database/zwave-device-list/devicesummary/616
I could not find any information about association groups or config parameters, so we need to see if it works correctly …
You need to wait for device approval and then update your zwave binding to the newest snapshot.

1 Like

Thank You Sir, for such a quick turnaround! Will keep my eye for approval and eager to get the change into my system.

Looking at the neighbor device AZR configuration devicesummary/248 - shouldn’t AMZ Endpoint 0 also have Basic linked to SWITCH_MULTILEVEL ? Sorry if I’m wrong, since I do not know (yet) what I’m talking about. Just associative debugging:)

Device is aporoved for a few days already. What struggle to understand - how to update binding/use the latest thing db?
I tried to switch my oh2 from stable to daily builds.
Uninstalled and installed Z-Wave binding. Checking ‘supported thing types’ from habmin ui, but AMZ not listed.

Is there any trick I’m missing or just need to be more patient? Thank You!

Actually that should do it if you are on the latest snapshot build.
Log into your karaf console ssh openhab@localhost -p 8101 and type bundle:list.
You should see the zwave binding version:

219 | Active | 80 | 2.1.0.201706122347 | ZWave Binding

It needs to be newer than the date of the last export for your device.

Thank you SiHui for support and looking at it. Sounds promising, but still something weird happens for me:(

Export for device http://www.cd-jackson.com/index.php/zwave/zwave-device-database/zwave-device-list/devicesummary/616 shows as done on 2017-06-13

bundle:list shows 06-16
206 | Active | 80 | 2.1.0.201706161409 | ZWave Binding

When I am in habmin, checking Configuration->Bindings->Z-Wave->Supported thing types - then AMZ Awning Blinds not present. Tried also removing devices and controller then uninstalling Binding and repeating from there - same. can’t find the new device and Things list shows them as unknown :frowning:

Could it be it’s exported, but not commited yet? Or I’m doing smtg wrong w local config?

Thank You!

You may be right, I could not find any merged database updates for the Fakro device … but to be honest, I don’t know if I have looked at the right place :sunglasses:

It’s not been updated yet - I will try and do an update tonight.

Oh, haha, no rush as long as I know it’s not me/my hw:)
I like experimenting - learned of device db, switched over to snapshots and installed/learned karaf console - thanks to the fakro blinds :smiley:

oh, have a great progress (somehow did not work yday by just uninstall/install’ing binding, but did full “upgrade” today and devices are getting recognized).

good:
can send on/off to the switch channel and it reacts as the “controller manual button” described in section 9 of the manual (e.g. clicking once starts the closing action, clicking second time stops it, third time continues … until fully closed … clicking again starts opening … until fully open).

bad:
what does not work for me yet - the multilevel switch and giving the open or close command. I wonder, could it be because channel type for 2nd channel is switch_dimmer instead of the blinds_control ?

Yes, changing to the blinds_control should give you the extra options.

I guess, it has to be changed at database level, not locally on OH installation?
@sihui, maybe you can help since you were kind enough to create the db entry:)
http://www.cd-jackson.com/index.php/zwave/zwave-device-database/zwave-device-list/devicesummary/616

Plus, I guess, need to add StopMove and UpDown properties (as in the ARZ roller shutter

Thank You!

Sorry, I don’t mess around with devices I don’t have, because I cannot test the results.
Please open an account on the database site and edit yourself (and test if the changes are working).

Good luck.

fair point (was not sure if there is a smaller group of editors for the db or anyone can do it). will give it a try:)

I’ve updated your access…

No - if you use the blinds_control, it should add these for you…