Fan Control Alexa - OH3.3 M2

I have a zwave fan working with Alexa where I can ask her to set the fan to a certain percentage, but I can’t ask her to turn it “off”.

I’ve added Metadata for the “powerlevel”:

it correctly appears in the Alexa devices:

Asking Alexa “Turn on Office Fan 50%” works perfect. I can also say “turn on Office Fan 0%” to stop the blades from spinning, but I would prefer to ask her to “turn off”.

I’ve added Metadata for the “endpoint.switch”:

which also appears in Alexa devices:

If I ask Alexa to “Turn off Office Fan”, she says that “Office Fan doesn’t support that”.

Have you tried to use the new metadata syntax?

You should use FanSpeed and PowerState to accomplish that. And if your device is a single endpoint, you can just model as Fan since both are default attributes for that device type.

Where do I set these? I have two items for the fan - the Office Fan Group and the office fan dimmer:


Do I do this on the dimmer, or just pick ‘fan’ on the group?

To set your group endpoint, set the Group item as Fan and your Dimmer item as FanSpeed and PowerState.

1 Like