Feed-Binding builded for 2.5.1 is not running

Dear Community,

I built the feed binding for OH 2.5.1. The maven build went through without any errors. Afterwards I put the bundle into my OH 2.4 runtime environment. After trying to activate the binding in my karaf console I got this error message:

openhab> bundle:start 234
Error executing command: Error executing command on bundles:
Error starting bundle 234: Could not resolve module: org.openhab.binding.feed [234]
Unresolved requirement: Import-Package: com.rometools.rome.feed.synd; version="[1.12.0,2.0.0)"

My next try was to start the OH 2.5.1 runtime and put the jar into the addons folder. Anyway, I wanted to view all my bundles and the ‘new’ feed bundle was not detected.

How should I proceed? Thanks in advance.

Best regards,
Jochen

This might be better posted to the Development category. The error is showing that there is an unresolved dependency and it looks like it is a jar file specific to your binding. In my mind, that means something went wrong with the build or is otherwise not correct in the pom or the link. The developers who can help with that are probably more like to see this and help over there. I think you can move it yourself. If not let me know and I’ll move it if you agree.

Thanks, moved!

You need to install the dependencies manually. bundle:install mvn:<groupId>/<artifactId>/<version>

Thanks Jan,

I tried to do that by typing

“openhab> bundle:install mvn:com.rometools/rome/1.12.0”

Here is the error message:

Bundle IDs:
Error executing command: Error installing bundles:
Unable to install bundle mvn:com.rometools/rome/1.12.0: org.osgi.framework.BundleException: Error reading bundle content.

Maybe it is necessary to go through the pom-file to find the error:

<?xml version="1.0" encoding="UTF-8"?>

4.0.0

org.openhab.addons.bundles org.openhab.addons.reactor.bundles 2.5.0-SNAPSHOT

org.openhab.binding.feed

openHAB Add-ons :: Bundles :: Feed Binding

com.rometools rome 1.12.0 provided org.apache.servicemix.bundles org.apache.servicemix.bundles.jdom 2.0.6_1 provided org.slf4j slf4j-api

Dear Community,

can anyone try to build and add an existing addon to his runtime environment and tell me which one works for him - so I can use the same addon. This would increase my speed for development. Thanks in advance. In the meantime I’ll try others.

Best regards,
Jochen

Hi

I am having the same issue. Just trying to test a small patch to lgwebos binding but cannot install the dependencies manually and get it to work using the 2.5.0.M1 docker image.

bundle:install mvn:org.apache.httpcomponents/httpcore-osgi/4.4.4
bundle:install mvn:org.apache.httpcomponents/httpclient-osgi/4.5.2
bundle:install mvn:org.apache.servicemix.bundles/org.apache.servicemix.bundles.xpp3/1.1.4c_7
bundle:install mvn:org.apache.servicemix.bundles/org.apache.servicemix.bundles.json/20140107_1
bundle:install wrap:mvn:org.java-websocket/java-websocket/1.3.2

all fail like this.

openhab> bundle:install mvn:org.apache.httpcomponents/httpcore-osgi/4.4.4                                                                                                                                                  
> 
Bundle IDs: 
Error executing command: Error installing bundles:
	Unable to install bundle mvn:org.apache.httpcomponents/httpcore-osgi/4.4.4: org.osgi.framework.BundleException: Error reading bundle content.

any ideas or suggestions?

1 Like

These bundles are probably not available in the 2.5M1 repo. They are if you switch to SNAPSHOT. Another solution is to take the bundle name, search it in Maven Central, copy the link to the jar including http:// (make sure you pick the correct version) and then use bundle:install <insert-link-here>.

Indeed, switching to SNAPSHOT worked, thx!