FGF-101 v2.1 FW3.4 suddenly offline

Hi there,
I’m having issues with my flood sensor.
Today I had the case of a flood, but it only gave local alarm, no messages to OpenHAB.
I discovered it went offline (last updates of temperature) some days ago.
I tried to bring it near the z-wave controller and removed the battery, but the temperature still doesn’t get updated and I don’t get any messages from the node on movement.

  1. Why is this happening?
  2. How can I bring it back to life?
  3. How can I monitor it’s offline-online state? (it always show online in PaperUI if the controller is online)

Can someone please help with this?

The clairvoyants left due to poor pay, Only mortal volunteers are left. Look especially at items 9. 10., 11, 12, 13.

How to ask a good question / Help Us Help You - Tutorials & Examples - openHAB Community

1 Like

Thanks for your quick answer, you’re absolutely right.
I didn’t update anything before it stopped working,
using org.openhab.binding.zwave-2.5.5-20200515.172819-7.jar
on OpenHAB 2.5.4
running in docker on a QNAP TS-251D
I tried to find out something through zwave-log-viewer
but didn’t see anything strange, except missing communication from the node.
All other Z-Wave devices are still working.
These are the affected items.

Number:Temperature Wassermelder_TemperatureSensor "Wassermelder Temperatur [%.1f°C]" <temperature> (gTemperatures, gHistory, gChart) { channel="zwave:device:controller:node10:sensor_temperature" } 
Switch Wassermelder_Tamper "Wassermelder Tamper" <Alarm> (gStatus, gHistory, gChart) { channel="zwave:device:controller:node10:alarm_tamper" }
Switch Wassermelder_FloodAlarm "Wassermelder Wasseralarm" <Water> (gStatus, gHistory, gChart) { channel="zwave:device:controller:node10:alarm_flood" }
Number Wassermelder_Batterieladung "Wassermelder Batterieladung [%s]" <Battery> (gStatus, gHistory, gChart) { channel="zwave:device:controller:node10:battery-level" }

There are no z-wave.log entries for NODE 10 except

NODE 10: Polling...
NODE 10: Polling deferred until initialisation complete

I found this thread which may help, but how can I avoid this to happen again?
We were lucky someone was at home to see the water!

Sounds like your device may be broken.

Maybe it’s just lost its settings. You could try re-including it. There’s a bit more to that than removing the battery.

Detecting a failed battery zwave device is a challenge. Most of the time, it’s asleep and indistinguishable from broken or missing.
If you have an Item that gets updated periodically (like your battery), you can detect when one or more updates gets missed. The expire binding is useful for that kind of thing.

I put the controller in add mode and added it again.
It got a new node id and is working now.

May it be broken anyway?
If not, why did this happen?

Thank you, I used timers until now, expire with UNDEF is better!