Fibaro Configuration

Hi All,

I am fairly new to OpenHAB and this is my first time posting so hopefully this is in the right place.

I got a Fibaro FGMS-001 sensor and am trying to configure it. I seem to be able to get light and battery readings in OpenHAB UI but cannot get the motion detector or temperature to work. Temperature did work at one point but it remained in Celsius and now it just won’t read. From what I read so far is that I need to add this to an association group but Habmin doesn’t list association groups or configuration parameters like it does with my other sensor. Any time motion is detected the device blinks but nothing is registered with OpenHAB.

Here’s my item list.

Contact Fibaro_Motion “Fibaro Movement: [%s]” (gMF) { zwave=“20:command=SENSOR_BINARY” }
Number Fibaro_Motion_Temp “Temperature [%.0f °F]” (gMF) { zwave=“20:command=SENSOR_MULTILEVEL,sensor_type=1, unit=fahrenheit,” }
Number Fibaro_Motion_Lux “Light [%.0f Lux]” (gMF) { zwave=“20:command=SENSOR_MULTILEVEL,sensor_type=3” }
Number Fibaro_Motion_Bat “Battery [%s %%]” (gMF) { zwave=“20:command=BATTERY” }

Any help would be greatly appreciated.

I have a couple of these devices and they are working just fine. My .items setup is the same as yours, except I want the temperature reported in Celsius so I do not have the property “unit=fahrenheit” set.

Have you correctly set up an association between the device and your Z-Wave controller (using e.g. HABmin)?

What does HABmin show? You might have a newer version that HABmin doesn’t know about - I updated the version codes for this device recently - are you using the latest snapshot?

Hi All,

Thanks for getting back to me. Chris > you are right. I found a newer version (1.9), earlier today, applied it, and now I see associations and configs.

I do have two other points for this. When assigning association groups, what is the preferred method? Right now I have the Z-wave controller (node1) in each group. Also, the device still seems kind of ‘off.’ I’ve been messing around with the settings trying to get it to perform consistently but cannot. Ideally, I’d like it to detect motion in a room, and after 3 or so minutes with no motion, turn off the lights.

I attached my config settings and my rule is shown below. Any help on this would be appreciated.

Thank you again,

rule “Kitchen Motion Lights”
Item Fibaro_Motion changed
if (Fibaro_Motion.state==OPEN)
Kitchen_3Way.sendCommand(ON) }
else if (Fibaro_Motion.state==CLOSED)