Fibaro FGBS 001 2001/801 on Openhab 1.8 Guide

If you’re trying to setup a new model (April 2016) Fibaro FGBS 001 multi sensor and having trouble getting it recognized in OpenHab 1.8 correctly, I’d recommend these steps below. I’m hoping this guide saves someone else the time to figure this out.

  • If the device and node appear but can’t be polled by Openhab, hit the B button three times on the sensor to activate it. I had to do this a few times before everything worked and I have to do it every time I reboot OpenHab.
  • Check your logs to see if the device type is 2001/801 or later. If so, you need to update the Z-Wave binding to 1.9. The binding jar isn’t packaged separately, so you need to checkout from master and compile yourself. You can use Git checkout on the whole repo, go to the z-wave binding folder, then do mvn package and drop the jar from the ‘target’ folder into your addons directory (and remove the 1.8 binding).
  • In Openhab, add the sensor to your controller in all 3 association groups. This setting will only appear if the device is properly recognized by Z-Wave (hence why upgrading the binding to 1.9 is necessary)

If you now reboot openhab, and wait a bit of time, the sensors should start to show up on the network.

I’m not sure what you mean by it not being packaged separately, but you can always download the nightly snapshot from cloudbees.

Ah, good to know. Thanks!

Do you have an example of what the temperature items would look like?

Examples for temperature items are in the wiki: