Fibaro FGBS-222 not reporting temperature sensors

I’m running openHAB 3.0.1 on a raspberryPi wit an aeotec z-stick Gen 5, with a bunch of devices. It all is working quite well. I recently added a Fibaro FGBS-222 with four DS18B20 temperature sensors. And that is where the problem is.

The temperature sensors seem to work and after reinitialising the device they also give me a proper reading that i can see in the event log. Switching on/off the outputs also works well and is very responsive.

But the only time when it reports the sensors temperature is when reinitialising or power cycling (sometimes) the device. It does it once and then stops.

It seems that wen i exclude the device, factory reset it, include it again and do not change any configuration it reports correct temperatures every time i trigger one of the outputs. Bet then when i update the configuration and enable automatic reports it stops working and only gives a reading when reinitialising.

I found a topic on the fibaro forum: Nasty bug with periodic reports in smart implant? - Smart Implant - Smart Home Forum by FIBARO that seems to describe my problem.

I have tried several configurations. No luck whatsoever. I have searched the openHAB community and did not see any topics that describe my problem. But i might have overlooked something.

Anyone has got any idea? If i can provide configuration or Thing properties. Let me know.

Upgraded Openhab. Excluded the device, factory resetted, added it again.

Changed/added the following parameters:

group_1: controller
config_66_1: 180
config_67_1: 1

And now it is reporting 0.1 celsius changes for all temperature sensors. So case closed for now. I will see if it keeps working.

1 Like

Same problem whit internal temperature. Did you upgrade to 3.1.0.M1 ?

They work fine for me. Two suggestions…

  1. The DS18B20 sensors must be attached to the device BEFORE you do the inclusion into the Z-Wave system (and therefore by consequence also before you add them to your OH system).

  2. Once included in OH you need to set some Configuration Parameters on the Things in OH as follows…

  • Temperature sensor threshold (for internal sensor): 5 (i.e. 0.5C)
  • Temperature sensor period (for internal sensor): 60 (i.e. 1 minute)
  • External temperature sensor threshold: 5 (i.e. 0.5C)
  • External temperature sensor period: 60 (i.e. 1 minute)

EDIT: also try setting the Thing’s Polling Period to 60 (seconds) as well.

1 Like

I don’t know if the upgrade did the trick solely. Ik had to make sure the parameters were set:

group_1: controller
config_66_1: 180
config_67_1: 1

From some reason config_66_2 did exist, but config_66_1 did not. It seems to set the polling period and precision for the reporting group group_1. I changed it yesterday and it is working pretty well.

Is it listed in the database item? If not, please update the database so others may benefit.

There is a current issue that the 3.x bindings are about 3 weeks behind the database.