Fibaro FGD 212 activating rule by scene number poll issue


I have some issues with triggering rules by scene from my Fibaro Dimmer 2. I use the native z-wave binding (2.1).
Tried to search the forum for similar issue but couldn’t find anything. Any help is appreciated.

So basically triggering a rule when Scene id changes to a specific number is not a problem.

First issue.
If I try to trigger the same scene in a row, OpenHAB does not catch this since there is no change in value. Using a postUpdate on the SceneID the first time the rule was triggered fixes this issue. Not ideal but an easy fix.

Second issue.
My systerm is set up to poll the z-wave nodes. Now running a postUpdate on the SceneID fixes the issue with triggering the same scene in a row, but when the node is polled the SceneID is updated and the rule is triggered again. Not so ideal.
So does anyone have a fix for this? Earlier i ran my z-wave nodes on a vera edge and I had multiple items I used to handle this. Basically I had a switch that also triggered together with the scene number (always after) This way I used the switch item as trigger for the rules.

Use received update instead of changed as trigger.

Thanks sihui, that solves my first issue at least :slight_smile:

Any ideas for the second one?
Feel like I have missed something here, I cant be the only one with this kind of issue with scenes on Fibaro.

The forum post below actually discuss the same issue, and there doesn’t seem to be a solution.
I’m a little surprised though, basically I cant see how anyone could get this to work properly with any z-wave device with a scene functionality. That is if they have polling enabled, but I would guess most have. Unsure if you can even turn it off from the z-wave binding.

Works without any issues (six FGR222 rollershutters), but I do not

poll any zwave devices.
Is there any benefit or usecase for polling zwave devices?

Hmm after playing with this for a while I do not see the problems I had before. It might be that I experienced the issues when running my z-wave network through the z-way binding. So it does not seem that polling of the z-wave devices cause the rules to trigger when set to received updated. Or it could be that I’m completely misunderstanding this and that my earlier problem was only caused by the z-way binding. Anyway thanks for the help sihui! :slight_smile:

I’m no expert on this but as far as i know the benefits of polling your devices is to have correct status of the devices, off course this should not be necessary if you have a “perfect” network where all messages are received. And the disadvantage of polling is off course increased network traffic.

In a “default” setup (without polling) all devices have a correct and recent status if the association groups are correctly set. Also the configuration parameters should be set that a device triggers and does not need to be polled (for example a luminance sensor).

I remember reading some threads about certain Qubino devices which may have some problems with that.
Here are some nice explanations from Chris how triggering instead of polling should work:

I thought default was about 30min poll intervalls?

Why did you get me started :wink: I have a few Qubino devices (dimmers) and have never had the time to investigate their faulty device statuses properly. And after reading for some hours now I think I’ll just leave them like it is :wink:
On a sidenote I’ve had a few of these “explode” as well.
Safe to say I will not be buying any Qubino dimmers in the near future.