Fibaro FGR-223 Roller Shutter 3

Tags: #<Tag:0x00007fc3fc5405e8>

thank you for the advice.
i ve the 2.5.0 snapshot.jar binding zwawe and i don’t have blind control 1… i ve only blind control.
i ve to update openhab or just the binding? where i can find it?

The device database is part of the z wave binding. So no need to update OpenHAB.
Which exact snapshot build do you have? Typically it has a 4 digit number or you may find a time stamp.
With the Karaf command bundle:list you should be able to identify it.
However I can’t tell how the channels are called in your version as I am running the “old” milestone release and have switch_dimmer, switch_dimmer1 and switch_dimmer2.
Which channels are offered to you in the thing configuration in PaperUI or HABmin?

I have problems to get FGR-223 Roller Shutter 3 running

The Log show the following message:

2019-06-15 20:48:15.723 [WARN ] [wave.discovery.ZWaveDiscoveryService] - NODE 19: Device discovery could not resolve to a thingType! 010F:0303:1000::5.1

2019-06-15 20:48:15.736 [INFO ] [g.discovery.internal.PersistentInbox] - Added new thing ‘zwave:device:88190bb8:node19’ to inbox.

BasicUI show the following Thing:
image

Thing details in BasicUI:

Z-Wave Node 019 (010F:0303:1000:5.1)

Unknown Device

This device has not been fully discovered by the binding. There are a few possible reasons for this -:

  • The device is not in the database. If the device attributes show that this device has a valid manufacturer ID, device ID and type, then this is likely the case (eg. you see a label like " Z-Wave node 1 (0082:6015:020D::2.0) "). Even if the device appears to be in the database, some manufacturers use multiple sets of references for different regions or versions, and your device references may not be in the database. In either case, the database must be updated and you should raise an issue to get this addressed.
  • The device initialisation is not complete. Once the device is included into the network, the binding must interrogate it to find out what type of device it is. One part of this process is to get the manufacturer information required to identify the device, and until this is done, the device will remain unknown. For mains powered devices, this will occur quickly, however for battery devices the device must be woken up a number of times to allow the discovery phase to complete. This must be performed with the device close to the controller.

Status: ONLINE

HIDE PROPERTIES

zwave_beaming true
zwave_class_basic BASIC_TYPE_ROUTING_SLAVE
zwave_class_generic GENERIC_TYPE_SWITCH_MULTILEVEL
zwave_class_specific SPECIFIC_TYPE_CLASS_B_MOTOR_CONTROL
zwave_deviceid 4096
zwave_devicetype 771
zwave_frequent false
zwave_listening true
zwave_manufacturer 271
zwave_neighbours
zwave_nodeid 19
zwave_plus_devicetype NODE_TYPE_ZWAVEPLUS_NODE
zwave_plus_roletype ROLE_TYPE_SLAVE_ALWAYS_ON
zwave_routing true
zwave_secure false
zwave_version 5.1

Item definition:

Rollershutter Jalousie_WZ_1 “Jalousie 1 Wohnzimmer” { channel=“zwave:device:88190bb8:node19:blinds_control” }

I run openHAB 2.4.0-1 (Release Build) on Raspberry Pi 3 Model B (latest stable version)
I have upgraded all installed software packages and applied the latest improvements

Please help to fix the issue

There are some good news about your issue.
First of all, your device is in the current database, second you have the better firmware version 5.1.
The bad news is, the device wasn’t available in 2.4 releases, so a later version is needed.
You need to at least update the Z-Wave binding by copying the .jar-file in the openhab2-addons directory. The latest snapshot can be found here.
Don’t forget to confirm you’re running the correct binding version, e.g. by using bundle:list in karaf console.

Thank you Martin for your quick reply. I tried your proposed solution but could the zwave-2.5.0-SNAPSHOT installed only but not active.

bundle list:

233 │ Active │ 75 │ 0.10.0.oh240 │ org.eclipse.smarthome.transform.scale
240 │ Installed │ 80 │ 2.5.0.201906151852 │ org.openhab.binding.zwave

Log:

2019-06-16 08:14:24.979 [WARN ] [org.apache.felix.fileinstall ] - Error while starting bundle: file:/usr/share/openhab2/addons/org.openhab.binding.zwave-2.5.0-SNAPSHOT.jar

org.osgi.framework.BundleException: Could not resolve module: org.openhab.binding.zwave [240]

Unresolved requirement: Import-Package: com.thoughtworks.xstream; version="[1.4.0,2.0.0)"

at org.eclipse.osgi.container.Module.start(Module.java:444) ~[?:?]

at org.eclipse.osgi.internal.framework.EquinoxBundle.start(EquinoxBundle.java:383) ~[?:?]

at org.apache.felix.fileinstall.internal.DirectoryWatcher.startBundle(DirectoryWatcher.java:1260) [10:org.apache.felix.fileinstall:3.6.4]

at org.apache.felix.fileinstall.internal.DirectoryWatcher.startBundles(DirectoryWatcher.java:1233) [10:org.apache.felix.fileinstall:3.6.4]

at org.apache.felix.fileinstall.internal.DirectoryWatcher.doProcess(DirectoryWatcher.java:520) [10:org.apache.felix.fileinstall:3.6.4]

at org.apache.felix.fileinstall.internal.DirectoryWatcher.process(DirectoryWatcher.java:365) [10:org.apache.felix.fileinstall:3.6.4]

at org.apache.felix.fileinstall.internal.DirectoryWatcher.run(DirectoryWatcher.java:316) [10:org.apache.felix.fileinstall:3.6.4]

For the steps to install the snapshot I followed the instructions on OpenHab FAQ

  • uninstalled zwave 2.4.0
  • reboot
  • copied org.openhab.binding.zwave-2.5.0-SNAPSHOT.jar to the openhab2-addons folder

It’s the first time that I installed a snapshot … I tried several times but possibly did something wrong. Any idea how to step forward or analyze?

I found the solution in the forum Latest Zwave binding missing module?

Now it works!

hi, this is my version:

276 │ Active │ 80 │ 2.5.0.201901242108 │ ZWave Binding

this is the list of channels on paperui

Is anyone running the new firmware (>=5.1) and can confirm that the status of the shutter is updated correctly after movement?

I am running 6 Roller Shutter 3 with Firmware 5.1

I am also using the 2.5-SNAPSHOT Binding, not the Milestone and not 2.4

I can confirm, that the operation is as desired. For the status updates, I force a REFRESH after each operation.

I was under the impression the mission update is fixed and there is no need of a REFRESH.
Do you get the updated state if you don’t refresh?

Not always, and not consistently for the 6 RS3, although they are all from one delivery and the same firmware version.

But, I also have two RS2 and I see the same behavior as I see for the RS3, i.e. consistent status (% open/closed) only when I refresh

Hm - strange. Now I don’t know if it’s working or not - Openhab is set correctly in the groups as lifeline/status update?
My RS2 refresh consistently after each movement without any need for manual refresh.
Can anyone else comment if they see updates or not?

Mine refresh as well, but sometimes with values, that are not correct. I do not know, if this is a problem of the device, of the openHAB Z-Wave binding or the Classic UI, iPhone App, because sometimes the values update but the icons not and vise-versa

In my rules I force a refresh and that seems to ensure that all get updated. I do this with a 1 minute delay after the action

Besides that the devices work well

if i use phisical switch in the wall no problem for the update.(in the dimmer channel)
if i use the dimmer channel to set position (e.g. 20%) there is the problem. after 1 second of running update position , not the real position but the position after 1 second. tomorrow i can make a video if you want.
no problem if i use with OPEN CLOSE STOP command in rolleshutter channel but i can’t use it on dimmer channel.

Here is one item definition for the RS3. In the 2.5-SNAPSHOT, there is NO switch_dimmer channel:

   Rollershutter	LIV_Jalousie_SR_Schalter	"Jalousie Wohnzimmer Süd Rechts [%.0f]"		<blinds>	(F3_Wohnen, gZWave, gJalousie)		["WindowCovering"] {channel="zwave:device:Razberry:node17:blinds_control"}
   Number		LIV_Jalousie_SR_Verbrauch	"Jalousie WZ SR Verbrauch [%.1f kW/h]"		<energy>	(F3_Wohnen, gZWave, gJalousie)		{channel="zwave:device:Razberry:node17:meter_kwh"}
   Number		LIV_Jalousie_SR_Leistung	"Jalousie WZ SR Leistung [%.1f Watt]"		<energy>	(F3_Wohnen, gZWave, gJalousie)		{channel="zwave:device:Razberry:node17:meter_watts"}
   Number		LIV_Jalousie_SR_Scene		"Jalousie WZ SR Scene [%.0f]"			<blinds>	(F3_Wohnen, gZWave, gJalousie)		{channel="zwave:device:Razberry:node17:scene_number"}
   Switch		LIV_Jalousie_SR_Alarm_Strom	"Überstromalarm: Jalousie WZ SR [%s]"		<alarm>		(F3_Wohnen, gZWave, gJalousie)		{channel="zwave:device:Razberry:node17:alarm_power"}
   Switch		LIV_Jalousie_SR_Alarm_System	"Systemalarm: Jalousie WZ SR [%s]"		<alarm>		(F3_Wohnen, gZWave, gJalousie)		{channel="zwave:device:Razberry:node17:alarm_system"}
   Rollershutter	LIV_Jalousie_SR_Schalter1	"Jalousie Wohnzimmer Süd Rechts 1 [%.0f]"	<blinds>	(F3_Wohnen, gZWave, gJalousie)		{channel="zwave:device:Razberry:node17:blinds_control1"}
   Number		LIV_Jalousie_SR_Verbrauch1	"Jalousie WZ SR Verbrauch 1 [%.1f kW/h]"	<energy>	(F3_Wohnen, gZWave, gJalousie)		{channel="zwave:device:Razberry:node17:meter_kwh1"}
   Number		LIV_Jalousie_SR_Leistung1	"Jalousie WZ SR Leistung 1 [%.1f Watt]"		<energy>	(F3_Wohnen, gZWave, gJalousie)		{channel="zwave:device:Razberry:node17:meter_watts1"}
   Switch		LIV_Jalousie_SR_Alarm_Strom1	"Überstromalarm: Jalousie WZ SR 1 [%s]"		<alarm>		(F3_Wohnen, gZWave, gJalousie)		{channel="zwave:device:Razberry:node17:alarm_power1"}
   Switch		LIV_Jalousie_SR_Alarm_System1	"Systemalarm: Jalousie WZ SR 1 [%s]"		<alarm>		(F3_Wohnen, gZWave, gJalousie)		{channel="zwave:device:Razberry:node17:alarm_system1"}
   Rollershutter	LIV_Jalousie_SR_Schalter2	"Lamellen Wohnzimmer Süd Rechts [%.0f]"		<blinds>	(F3_Wohnen, gZWave, gJalousie)		{channel="zwave:device:Razberry:node17:blinds_control2"}

The Schalter1 is for up and down
The Schalter2 is for the lamellas

This is what I read in the fibaro forums. Do you have the latest firmware?

it’s so strange. do you have see my snapshot? i have only one rollershutter e two dimmer channel.
you have three rolleshutter channel, it’s so strange…

Spaceman_Spiff yes i have 5.1 firmware

You may want to delete the device and add it again from the inbox. This is NOT removing/adding from the controller

i have delete the device and add again but nothing…i have only one rollershutter and 2 dimmer. what is your version of zwawe binding?

my is 2.5.0.201901242108

This one

https://ci.openhab.org/job/openHAB2-Bundles/org.openhab.addons.bundles%24org.openhab.binding.zwave/

Which I put into addons