Fibaro FGSD 002 not getting data


I have 9 Fibaro Smoke detectors, FGSD-002. All get included OK but I do not get any values from any of them.
When I included them, they all got discovered as smokedetectors:

I have added items, or added them when linking but I do not get any values.
I have tried waking up the devices standing right next to the z-wave stick but without any luck.
My log shows the following:

It is the same for all items added to all smokesensors. I do not have problems with any other devices.

Any good advice out there?
I’m running OpenHab2 on a virtual computer running Ubuntu 16.04.


Which version of OH2 (and the zwave binding) do you use? The smoke sensor seems to be a little “special” to get it going and Chris made some changes to the binding recently. Maybe you haven’t the latest version?

And have you added them just in the last minutes/hours? If so, let them wake up some more times (preferrable the automatic wakeup, not the triggered one). There is some data to be transferred and maybe the device “needs some time”.

I run version: 2.0.0~20170103034422 of OH2. Not shure where to find the version of the binding.
I first added all a couple of days ago. Yesterday I removed them all with “exclude devices” and added them again. So they all have been connected for aprox 24 hours now. What I see on all of them is:

And for wakeup interval:

Not shure how it handles the 0 sec. update interval. For now I try to get one up and running before I try the other ones but this one has had the “pending” for 24 hours now…

I have used the smoke sensors in Homeseer and there it was no problems getting the data.

This should be ok.

This also could be a problem. Have you also resetted the device itself? I did the same with my smoke sensor and have realized that they were nevertheless some “artifacts” left on the controller. Every new inclusion was successful, but I couldn’t communicate with the device. I had to use a tool called Zensys to remove the old nodes. See here:

You can check if this is also your problem by enabling DEBUG logging and then do a manual wakeup of the sensor (tripple button press). Does this produce any logging informations? If so, then it’s alright. If not, you might have the same problem as me.

This is a good approach.

Ok… So now I have deleted ALL my smokesensors and shadows of them with zentool. Then I tried adding one.
It came up OK in “inbox” so I added it as a thing and added a couple of items. So far so good…

Then I check some parameters because I do not get any values.
First is wakeup interval that is 0. Try to set it to i.e 60:

It has been stuck at pending for over 1 hour. Then I check Association Groups. All empty so I try to set OpenHab to the 1 group:

Also stuck at “pending”. I have tried waking up the device about 50 times standing right next to the Z-wave stick…
The FGSD002 seems to be impossible to get to work :frowning:

Anyone got any good advice?


Maybe I have one. :wink:

In fact, I do expect a similar behavior with the recent build. I hope it’s related to a minor code-change in the binding. I’m talking to Chris about this issue here:

Let’s see if he can figure it out.

Don’t give up. The device has worked properly before. So we will get this going again.

Great. Looking forward to feedback and maybe a solution. I have 10 of them :stuck_out_tongue:

I’ve made some (quite positive) progress with my re-adding of the sensors. See the link above and my latest answer to chris.

After the re-add and two manual wakeups, I got the device initialized and the xml was created.

Maybe you’ll give it a try and try it yourself?

Hmmm… What answer are you refering to here? Kind of lost now :smile:

This one:

You should:

  • delete the thing and the node xml (only if the device was fully initialized. Otherwise I would suggest to exclude it again and also delete all shadows in the controller, followed by a reset of the device)
  • update/upgrade your installation to get the latest zwave binding (yours is from 2017/01/03 and the probably necessary changes in the binding were on 2017/01/09 (be aware of the latest changes in the repository structure yesterday!))
  • check if you have the latest binding (log into the karaf console and type bundle:list to get a full list of all installed packages).
  • re-add the device (or include it again, based on what you did above). Check the configuration parameters. Do update/change them if necessary. Wake it up 2-3 times (for me 2 times were enough) and see if the xml was created.

Ok. I will give it a try in a few hours. I belive it is fully initialized so deleting the thing and xml is my first try.

Thanks for the good instructions

What changes do I need to be aware of?
Will a normal

sudo apt-get update 
sudo apt-get upgrade

be enough?

If an xml is there, it should be fully initialized.

No. The apt-get repository switched over from cloudbees to bintray yesterday. And another change has happened. See this both threads:

So you should get your standard OH installation up-to-date first. If you made all the necessary changes, you can use apt-get update/upgrade again. And after that, continue with the Fibaro problem.

I did the switchover now.

I’m not sure if its just a placebo effect, but the whole zwave part seems much faster now. The traffic between the devices after a server reboot is over after a few minutes. Earlier this could take 30 mins or more before everything settled.