Fibaro Flood Sensor not possible to add as a Z-wave device


(Samir E.) #1

Hi all, have a bit of a problem adding a Fibaro Flood Sensor to my openHAB 2.3 running on Windows 10 with an Aeotec Z-stick gen 5 connected and working. The other z-wave devices are working fine. I can see the flood sensor device in the inbox and it is possible to add it as a thing but going further generates an error:

FloodSensor

Unknown Device
This device has not been fully discovered by the binding. There are a few possible reasons for this -:

Log is attached.Logmessages.txt (12.8 KB)

One of the reasons can be that it is not in the database it says. I have read about this:
https://www.cd-jackson.com/index.php/zwave/zwave-device-database/zwave-device-database-guide

but to a complete noob there is not much I understand there. But if I look up Fibaro devices the database seems to miss the Flood Sensor:

In the link above about the database it also says that I should write in the forum about this so someone more experienced can possibly help with this.

To me it seems like it is simply missing in the database but maybe there is something else going on.

Some info about the flood sensor:

I am a bit lost where to go from here, if anybody has some suggestion it would be very appreciated!


(Mark) #2

There are three FGFS101 entries in the database. I’m successsfully using firmware version 25.25 of the device.
https://www.cd-jackson.com/index.php/zwave/zwave-device-database/zwave-device-list/devicesummary/127
https://www.cd-jackson.com/index.php/zwave/zwave-device-database/zwave-device-list/devicesummary/392
https://www.cd-jackson.com/index.php/zwave/zwave-device-database/zwave-device-list/devicesummary/408

Try manually waking up the device a few times so that the binding can interrogate the device for all its information/properties.

manuf:271 (0x01F)
type:2817 (0x0B01)
id:4099 (0x1003)

It looks like you have this one.
https://www.cd-jackson.com/index.php/zwave/zwave-device-database/zwave-device-list/devicesummary/392


(Mark) #3

If after the above, you still have issues, you should consider upgrading to the latest version of the binding, as the database entries for this device may have changed since the 2.3 release (which is almost 6 months old).


(Samir E.) #4

Thank you all for the replies, I will try this and dig deeper and report back!


(Samir E.) #5

Hi,
thanks for all help! The first suggestion made no change, I tried excluding, resetting and including again but nothing happened.

After installing the milestone 5 of 2.4 it worked after following the exact procedure explained in the document. However all my rules in PaperUI disappeared but this is a good time to do the rules the right way instead (in files).

Thank you again!


(Samir E.) #6

Hi again,
sorry but I have more problems with this Fibaro Flood Sensor. I am sure that I am doing something wrong and maybe it is quite obvious to a pro but I am a noob unfortunately.

Same config as beginning of the thread, Windows 10 Pro. Fibaro Flood Sensor FGFS101. However now running on openHAB 2.4 Milestone 5 as per request above (which helped to add the thing).

It is now added nicely to openHAB as a thing, all looks fine and the thing is also linked to items.

image

Items:
image

If I do a manual wake up, it also looks fine in the log:
Flood Sensor Error Log.txt (620 Bytes)

But when I manually trigger the flooding (two wet fingers on the contacts), I can’t get the item rules to react. The Flood Alarm is reacting in itself as expected (beeping and led blinking).

I have done some different rules just to get it going but nothing happens. Nothing in the log and no reaction in the rules:
image

Properties:


UPDATE
The temperature and battery level are actually possible to catch as events in rules when waking up the Flood Sensor manually:

9:14:35.656 [INFO ] [smarthome.event.ThingUpdatedEvent ] - Thing ‘zwave:device:70e495c5:node6’ has been updated.
19:14:35.783 [INFO ] [g.eclipse.smarthome.model.script.RULE] - Flooding sensor battery changed
19:14:35.770 [INFO ] [g.eclipse.smarthome.model.script.RULE] - Flooding sensor temperature changed
19:14:39.917 [INFO ] [smarthome.event.ItemStateChangedEvent] - FGFS101FloodSensor_TemperatureSensor changed from NULL to 22.77 °C
19:14:39.920 [INFO ] [smarthome.event.ItemStateChangedEvent] - FGFS101FloodSensor_BatteryLevel changed from NULL to 21

But no matter what I do I cannot get the most important event to fire in a rule, the flooding. This leads me to believe that I am doing something wrong with that event - should it be formatted in a different way? I wrote this just to catch everything:

when
Item FGFS101FloodSensor_FloodAlarm changed
then
logInfo(“RULE”, “Flooding sensor activated”)
end

Also adding Debug level of log for z-wave when I woke up the sensor.
Flood Sensor Error Log.txt (9.5 KB)

END UPDATE

Is there possibly someone who can see where the problem is or come up with an idea on how to troubleshoot more…?


(Samir E.) #7

No one having any suggestion at all…? Feeling a bit lost here, I have no idea on how to go on. Simply cannot get the flood sensor to trigger a rule when the flood sensors are activated (temperature and battery works fine for some reason). Not even with “Item FGFS101FloodSensor_FloodAlarm changed” as the trigger, nothing happens.


(Mark) #8

The configuration looks ok.

The wakeup looks fine (although there’s not much going on).
ZWave%20Log%20Viewer%202018-12-05%2012-02-57

I would suggest you capture a zwave debug log when the device is triggered with water. That will better reveal what’s going on.


(Samir E.) #9

Hi,
thank you for your reply, I have attached the debug log. But from what I see when I activate the flood alarm, absolutely nothing happens with the device in the debug log. To get some sort of response, I did a manual wakeup and that is what you see in the log (at least that is what I see). So no reaction with a flood event, only temp and battery. But maybe I just don’t read it correctly.

I wanted to have the debug command in the text file so that is why the log goes from the moment I wrote that to log:tail and then the log entries. The actual debug log starts at 18:25, log entries before that are not related to the debug log so to speak.

So, to be clear, I activated debug log, then activated the flood alarm, saw nothing in the log and then did a manual wake up at 18:25.

Z-Wave Debug Log.txt (15.8 KB)


(Mark) #10

If you activated the alarm and there’s nothing in the log, then the device isn’t sending anything. That’s really odd, considering the device is beeping because it detected water.

Are you certain association group 1 (LIfeline) is set to the controller?


(Samir E.) #11

Hi,
I did set it from the beginning but then I reinstalled the system and did not actively set it again. It says it is on the controller by default, however I cannot confirm that. I have now actively set it to Controller and will test again this evening.

This is how it looked before I actively set it:

This is how it looks now:


(Samir E.) #12

SOLUTION
So, there is obviously no “main controller by default” for association group 1 (LIfeline), you have to manually set it to the controller. And then it works!

Wow, thank you soo much for the help, really appreciated!