Fibaro Floodsensor FGFS-101 ZW5 v3.4 not full initialised

  • Platform information:
    • Hardware: VM
    • OS: Ubuntu 18.04.5 LTS
    • Java Runtime Environment: openjdk version “1.8.0_275”
      OpenJDK Runtime Environment (Zulu (build 1.8.0_275-b01)
      OpenJDK Server VM (Zulu (build 25.275-b01, mixed mode)
    • openHAB version: 2.5.10 Release Build
  • Issue of the topic: Fibaro Floodsensor FGFS-101 ZW5 v3.4 not full initialised

Hello OpenHAB Community,

I am having a problem with the above mentioned flood sensors. The error is discussed elsewhere in the forum, but should be fixed in the version I am using.

The problem is the recognition of the device. I currently have the following status when I integrate the device into my Z-Wave network:

I have already tried the following steps to solve the issue:

  • delete devices and create new ones
  • Replace the battery in the device with a new one
  • Press the wakeup switch on the device several times (the sensor is currently located exactly next to the controller)
  • My Z-Wave Controller is a Z-Wave Europe GmbH ZMEEUZB1 USB Dongle
  • Wakeup interval set to 60 seconds

I set the logging to DEBUG to limit the error. Unfortunately, my OpenHAB / Z-Wave knowledge is not enough to make sense of it.

Logging when integrating. The device has the NODE 16 designation in my network:
debug_FGFS_101_v2_1_integration.txt (223.6 KB)

this is the device I use. (maybe the version numbers are relevant):

Does anyone have any idea what else I can do?

As with all battery powered Z-Wave devices, you need to be patient and wake them up manually a lot of times until the init process is really finished.
Don’t forget to increase the wakeup period again. My flood sensor is an older model of what you have, but back then I lost app. 20% of battery capacity in only 4h as I did not check all parameters again after the device was fully initialized. The newer one may have other defaults, but is is never wrong to check everything again before letting the devices do their work unsupervised.

1 Like

To be honest, I cannot hear this “be patient” anymore.
I have battery devices that are still “unknown” for month now. During this period, I waked them up for about 100 times. Still unknown.
I now refrain from buying any further Z-WAVE device.

I can understand that very well, being in the same boat. Unfortunately it is still true that they need to be woken up numerous times to get that init pahse finished. But once that is accomplished it works rather smooth.
There may be other issues influencing your situation. Waking up devices for 100 times and others still “unknown” for months is not normal. E.g. ghost nodes may impact your Z-Wave network. You may try to switch the Z-Wave binding to debug mode, post a log file that covers a relevant period of time and we try to figure out what is happening.
The how-to can be found here.

Thanks for the quick reaction here in the forum. Then I will wait patiently until my device is recognized. What if I use several of these devices? does every device have to go through this process or are other devices recognized immediately? Does it make sense to integrate all devices at the same time in order to achieve faster detection? Are there empirical values ​​which wake-up interval should be set if the device is still in the detection phase? I am not very familiar with the z-wave protocol.

Every device needs to be made known to the controller individually. The controller assigns a unique ID to every device. So you need to go throught that process for every single device.

There is no special technological barrier to do it for several devices in parallel. I see 2 limits:

  1. The amount of traffic that the wireless Z-Wave protocoll can transport.
  2. The time that is needed by the controller to process the data.
    As long as we are talking about a few devices that should not matter. As you need to wakeup the devices in some form (I assume you will do that manually) there is a practical limit in the number of devices you can do this with anyway :wink:

You can set the wakeup period to the desired setting that suites you in the long run as you override it anyway by waking up the device manually. At least waking them up manually until they are fully initialized is what I’m doing.