Fibaro Motion Sensor all channel showing NULL


I have managed to add a Fibaro Motion Sensor with z-wave to OpenHAB running on my rasp-pi, but all the values are shown as NULL.
Some people said to remove and add the device again or to wake it up ( tripple press the button ) 2-4 times. I have tried both, removing and adding it again, multiple times, left it there for an hour or just tripple pressed (wake up) it 6-7 times every time the blue light would shutdown and it is still showing NULL on all the channels.

Anyone has any idea ?

The binding does not allow enough time for full configuration after initial inclusion, so rewaking is necessary. If this is anything like my fibaro motion device, the wake is only one push, about a second. Three pushes send a NIF that is great for inclusion, but not waking. Try the one push a time or two.


Thanks for the reply,

I tried to remove the device and add it again, then pressed the button for 1s over and over again in interval of ~30s for longer than I want to admit, still no value showing up, sadly

Too bad. What is the device model?

Generally excluding and reincluding just starts over.

The 1 second is just an estimate. Could try .5 sec. Also the sleep timer is 5 seconds, so if it does wake, probably only have to wait 10 seconds between attempts.

Don’t have anything else at this time, but maybe someone else does.

Edit: so something obvious I forgot to ask, you have already linked these channels to items? I think there has to be items linked before they are populated. Also on the UI page for the device is there a 5 lines at the bottom including reinitialize device? If yes, you are complete, just need to link items.

The exact model is the " FGMS-001" bought here:

I tried keeping the button until the purple light lit up, waiting until it closes and trying again over and over :crazy_face:. I’m getting a bit desperate, I have 2 of those sensors and 3 others that are having issues “converting” from smartthings to openhab, it’s getting a bit expensive if I can’t figure it out :pleading_face:

Sorry I didn’t see your edit in time, probably didn’t refresh the page or idk.

At the bottom of the page for the “Thing” there is only 4 options + the “delete” :

And yes, I am very new to openhab so maybe I did it wrong, but for other devices I just clicked the “thing”, went in “channels” and “Add equipment to model”, then selected the different channels I wanted, like “battery, motion, temperature, etc…”.

I have other zigbee devices working, the two fibaro are my only z-wave devices, the discovery seems to be working it’s just afterwards that it doesn’t work

  1. So I have that device and it has worked for some time, so I’d be optimistic.

  2. Need five lines like this to mean initialization is complete.

I would try to create items for the channels that you want. Battery devices may not populate until they get a signal or wake. I know my battery level says null right after creation, but eventually populates. It’s late here, so I have no more for tonight.


Did a quick look this morning and realized from your screen shot that you are already linked the channels to items. Sorry for any confusion, my bad.

A couple of questions, just to help rule out other issues; If you click on one of the null items, does it show online? On the UI page for the thing “MotionSensorSalledebain” is there anything at the top under STATUS besides the ONLINE? Again on the UI page near the bottom is the controller shown in association group 1? Lastly is there a wakeup interval shown right above the 4/5 lines at the very bottom?

If yes to all, I’m sticking with the initialization not complete idea. The last step of initialization is called DYNAMIC VALUES which should populate your items. The next thing would be to put the zwave binding in Debug (to try to get more info on what is happening) and then try the B button push. The instructions for Debug are at the very bottom of this website under “if things do not go as planned”.

I’ve had this device for three years, but vaguely recall trouble with initialization. The device can do a network strength reading that I recall needs to be solid green. Try the button pressing as close to the controller as possible. I don’t think purple is a good color.


1 Like

I have two Fibaro devices. One is a motion sensor and I remember it being a bear to get working. That was a couple years ago. The other is a water leak sensor I just purchased. Every other zwave device I have, as soon as you pulled the battery strip out, they pop up in the inbox. The Fibaro took several tries to get fully configured. Don’t exclude and re-include, just keep waking it
Some times it takes what seems like way to many tries

Hi! Thanks for all the replies :slight_smile:

I left it there for an entire day without any values showing up, I pressed the button for 1-2s a couple dozen times over the day. I know this sensor work since it was working with my SmartThings hub.
It feels like if it was just “waiting to wake up” it would’ve had plenty of time at this point :frowning:

The items (the thing but also the items with NULL) does show ONLINE, even though I’m 50% sure it keeps showing that even if I unplug the device.

I will try the Debug tomorrow, I didn’t knew that existed!

So I was fiddling around trying to get the debug console to work when I had a notification / inbox message in openhab, saying there’s a new z-wave device.
I have 2 of these devices and only one had a battery in it for the past 2 days, so after saying “what the f*” out loud, I added the newly discovered device and after 5 second the temperature and motion status appeared :expressionless:
I removed the other '“Thing” and it now seems to be working well indeed!

The new one does have a 5th option to reinitialise the device :

When trying to add the second fibaro device, I see there’s 3 new z-wave device with previous node ids (3-4-5) whereas the “new” one with working values has an id of 6. Maybe I’ve been adding previously discovered device, after they were reset ?

The second fibaro sensor worked right away too, even though I was struggling with that one too. At that point I’ll take it :slight_smile:

Thanks everyone for your help,

Great !

I don’t know if you did this, but you need to use the Exclude devices option on the controller before trying to reinclude the device. Based on your report I’m guessing you just factory reset the device or did not get it fully ecluded. Anyway it sounds like you might have some zombie nodes. If so, they can cause a problem in Zwave responsiveness down the line. Check the forum for removing Zombie nodes and/or take a look at this post.

Again great

I agree with Bob

Damn, thanks again :laughing: !

I went with an old version of “PC Controller” on Windows to remove the 3 nodes, put the stick back in the rasp-pi and the ghosts / zombies seems to be gone for good.

Now there’s my “buttons” to figure out and then I can start “actually” working with the automation system, getting tired of getting out of bed to go close the lights that I keep forgetting to manually close :laughing: