Fibaro Motion Sensor not communicating all over sudden

  • Platform information:
    • Hardware: Raspberry pi 3, RaZberry
    • OS: openhabian
    • Java Runtime Environment: which java platform is used and what version
    • openHAB version: 2.4
  • Issue of the topic: please be detailed explaining your issue

My (only) motion sensor stopped working weeks (might be month) ago. Yesterday I had time and mood to investigate it. I quickly came to the point: ok, it is recognizing motion (it is blinking) so it must be something outside of the sensor itself. So I deleted it from OH and reseted. Adding it again worked w/o problems. But it still does not send any commands to the controller. No motion, no temp.

What else can I do?
IMHO it is not broken, the detection works, the inclusion works.

association to controller missing ?

1 Like

low battery?

1 Like

Did you also remove (exclude) it from controller?

If so, after including again,
you have to wake it up 10 times up to 20 times by triple pressing the button.

2 Likes

If you not have removed it from controller in this following way, you now have a dead node.

In HABmin: select device–> Tools–> Show advanced settings

image

Steps:

  1. Set device as failed (if it is really failed)
  2. Remove device from controller

Do I really have to set it.to failed before removing it?

No. Only if it’s failed.

Normally you should just exclude it. Go to controller in HABmin. Tools --> Show advanced settings
–> exclude devices --> triple press button on Fibaro Motion sensor.

1 Like

I did delete and reintegrate a 3rd time. Now it is working.
The thing appears three times in my inbox: node2 (that was the number for ages), node33 and node35. The last one is working. I just put the other two to ignore. Is that good or is there better solution for this?

In HABmin, add the other Things and try marking them as Failed. Hopefully that will delete them from the controller. Phantom nodes can cause network routing issues. You can then delete those Things. If they keep being rediscovered, we may need to try something else.

1 Like

I get a warning “Remove node 33 failed - node was not found” when I try to set it to failed.

@chris400

Then you need an other solution.

You need a Windows PC.
Install this software on it:

Z-Wave PC Controller 5.38

Or this software:

Zensis Tool 4.7

Stop Openhab. Unplug controller stick, if your openHAB is on a Linux machine.
Plug your controller stick into Windows PC.

Install the driver for your controller stick for using a virtual COM port. (e.g. COM3)

Open “Z-Wave PC Controller 5.38” or “Zensis Tool 4.7” and follow these steps:

  • select correct COM port.
  • highlight your dead node
  • Send NOP
  • Send IsFailed
  • Send RemoveFailed

Details you can find also here.

Here a picture of the tools frames (Zensis 4.7):


.

Please note for the future that you first exclude the node from the controller before you reset the device (=node).

1 Like

@chris400

Using “Z-Wave PC Controller 5.38” (I’ve never used it for this case!)
.


.


.


.

.

I hope I have labeled everything correctly, you are welcome to correct me!

ALL STEPS YOU CAN FIND HERE. There are also other links to all kind of removing topics…

1 Like

Much :heart: for your effort - but I have a RaZberry

I have found the following topic which I am monitoring closely from now on

1 Like

I do not know if it would work but you could shut down Openhab and try OpenZWave Control Panel It could likely remove the node.

1 Like