Fibaro Roller Shutter 2 Setup Problems - maybe communication?

rollershutter
Tags: #<Tag:0x00007fd30fabb780>

(Jonas) #1
  • Platform information:
    • Hardware: CPUArchitecture/RAM/storage
      mac Mini
    • OS: what OS is used and which version
      Latest Mac OS
    • openHAB version:
      2.3
  • Issue of the topic: please be detailed explaining your issue

Hi!

I have serious issues with my roller shutter.
I can use it and it is going up and down.
But i feel that there is something wrong with the stop command.
whenever i use it to stop it during operation the roller shutter just slips through.
it is not fixed in place but just falls down.
I wonder how this is even possible …

then after a delay that varies a lot it stops. sometimes it falls down completely …
has anyone made similar experiences?

i can post a video if necessary.


Rollershutter	WoZi_Jalousie_Balkontuer	"Rollladen Balkon [%.0f %%]"	<rollershutter>	(GrJalousien)    ["Blinds"]	{channel=blabla"}
  • Services configuration related to the issue
  • If logs where generated please post these here using code fences:

(Harry) #2

I don’t think it’s a OH or Rollershutter-problem.
What kind of motor and gear do you use?
Do you have only one rollershutter withe Fibaro?
Maybe a video can help.


(SiHui) #3

Bad reception? Place the little black antenna somewhat different. Or if possible place your zwave stick near to the device.

No. :sunglasses:


(Harry) #4

What is it a rollershutter or a jalousie?
What do you mean with slips through and falls down accurately?


(Markus Storm) #5

I’d enable zwave debugging first and watch messages to find if there’s messages getting lost and where the delay really is located.
If I was to take a guess then its that your zwave mesh is bad. Use habmin to see your shutter node’s neighbours and try to heal that node.
Eventually move to the dev binding - unlike the 2.3 version, it’s healing the network once a night and comes with a feature to handle Fibaro proprietary messages.


(Chris Jackson) #6

I’m not sure I understand what “slip down” means? This sounds like it’s a physical thing - ie the motor has stopped, but the blind is not holding position, and is slowly dropping in an uncontrolled way? If so, I very much doubt that this will be a ZWave issue - it sounds more like a motor, or physical configuration issue. I don’t think this sort of thing would be caused by RF issues, or mesh or lost commands…

Of course, if “slip down” means that the motor is running, then that’s a different story.

As suggest above, you can confirm this by checking the ZWave debug logs to see if there is any traffic.

Another suggestion might be to power off the power and see if it still moves - this would again confirm that there’s an issue with the motor (eg no backtourque) or simply that something isn’t quite connected up properly and the spindle is partly free-running…


(Vincent Regaud) #7

Your symptoms read like a physical fault (motor or gear possibly)

Is the right thing to do


(Jonas) #8

Hi

thanks for the fast replies!
I already thought of a hardware problem but that’s not the case …
i used a raspberry with z-wave shield before and it worked great.
before that i had a self built arduino with relays and it worked as well.

it blocks but only after a few seconds and sometimes it does not block at all.
i attached some videos to make my problem clear.

i could not open my shutter but is there really some kind of clutch? there has to be or i can’t understand how this thing works at all :wink:
Working - with delay
at the end of that video you can hear it falling down again.
Falling down

PS: The z-wave stick attached to my server is 5 m away and there is no wall inbetween …


(Jonas) #9

[quote=“chris, post:6, topic:47467”]
physical fault[/quote]

not the case. :slight_smile:


(Chris Jackson) #10

Why not? Looking at your “falling down” video, it does not look like a controlled descent of the blinds. To me, it looks like a physical issue. If it were a problem with the ZWave moving the blinds down, then the blinds would move at a standard and controlled rate. In the video, it looks to me like it is accelerating - ie it’s uncontrolled.


(SiHui) #11

At least the “falling down” is a hardware problem!
Check the safety pin:
1
Check proper connection between motor and fitting:
2

For the delay I would do a proper calibration: set parameter 29 to 1. Check hardware first :sunglasses:


(Jonas) #12

Hi!
Okay, ill dismount it and have a look.
Thanks!


(SiHui) #13

Also check if the motor is fully inserted into the rollershutter guide/track.

This picture shows wrong setup (too much of a gap):

gap


(Jonas) #14

Hi!

I finally had some time to check it out yesterday.
i completely dismounted it after checking for the points you mentioned to see if something else is going wrong.
Everything seems to be adjusted quite fine but i still get this issue.
After 2 h yesterday it seemed like i solved it but it was only because of the motor was warm (i think).
Today it’s falling down again …
My setup looks differently and i can’t see a manufacturer label to check the instructions for increasing friction or similar.
i have 2 screws for adjusting but it turned out that these are only for adjusting the upper and lower end position (almost broke my roller shutter because i did not know in advance) …

Any suggestions? Pictures below


(Markus Storm) #15

Find out if it’s a communication problem first.
Do you have a switch attached to your actuator? If no, do so now now that everything is accessible, and use it to “send” commands and see if the problem persists. If so, it’s clearly a HW problem and please don’t expect us to remotely debug your HW. You should be calling someone in to know and eventually replace that HW.


(Jonas) #16

Good point! I will attach a Switch this weekend and report here! :slightly_smiling_face: