Fibaro Roller Shutter FGRM-222 with Venetian Blinds - Lamellas Position

Tags: #<Tag:0x00007f617e5d3180> #<Tag:0x00007f617e5d2f28> #<Tag:0x00007f617e5d2c58>

Hi there.

As subject suggests - I have a problem with setting up FGRM-222 with Venetian Blinds. E.g.

I defined in items file:
Rollershutter Shutter_Wohnzimmer_Left “Shutter Position[(%d)]” (GF_Living,Shutters) { zwave=“4:command=switch_multilevel,invert_state=true,invert_percent=false”}

And in sitemap file:
Slider item=Shutter_Wohnzimmer_Left sendFrequency=400 switchSupport

I also set FGRM-222 configuration to Venetian Blind mode with positioning.

The calibration went OK and with this setup I can adjust blinds position with slider easily. But the problem in this case is that Lamellas always adjusted to same angle - looking up, doesn’t matter if going up or down - relay manages this automatically.
So my question is - is there any way to adjust Lamellas angle in the same way, as blinds position - with slider and independently of it? Fibaro Home center can manage it somehow, and I believe it’s just a matter of configuration. Anyone got it working?

No solution, sorry. Bad news for me, too, as I’m about to go for this setup, too. I already have the FGRM-222, just my blinds have not arrived yet.
According to this link (sorry, in German), to set the angle will only work with Fibar command class (set param #3 to 1), which is what Home Center uses as well. Have you tried playing with params #13 and #17 ?
You could try the Fibaro support forum and/or contact their support.

The FGRM222 command class is already support in openHAB :slight_smile:.

1 Like

Great - thanks, @chris.
So @Artyom_Syomushkin, see if param #3 = 1 makes a difference .I did a quick browse of the Fibaro forum, several mentions of this problem and same solution there, too.
If that still does not work, check if to (additionally) put the controller into association group 2 makes a difference. The manual also mentions venetian blinds will work with momentary switches only. Eventually try param #14 = 1 (even if you don’t have switches attached).

I made my own by using two relays and arduino, however the fibaro unit looks nice. A bit pricy though, around 70USD for one unit.

Param 3 is 1 - as I found this has influence on reporting of blind position. E.g. with Z-wave command class it was showing something like 96% when blinds were fully closed, but with Fibaro class it shows correctly 100%. But it has no influence on Lamellas and blind control.
Maybe to make it more clear - I don’t even know item binding configuration to control lamellas angle. E.g zwave=“4:command=switch_multilevel” controls blind position, but which text should lead to lamellas control?

Param 10 is set to 2
Param 13 works as suggested - but this doesn’t help much, because, as this topic about, Lamellas angle is zero, and I can not change it yet with OH. So they return to zero - e.g. looking up.

I will check about association groups.
BTW According to FHEM Forum(by german link above) FHEM is able to control Lamellas. So why OpenHAB can’t?

I never understood this either.
According to this, there’s a Fibar command to allow for setting blind position and lamella tilt in one go. So we need to pass two numbers in one command to the zwave device, but I don’t see how to do that with a single rollershutter item definition.
In Fibaro forum, someone mentioned there’s a ‘hidden master’ and a ‘slave’ device in Fibaro Homecenter for his FGRM-222 and he had to select the other one to make lamella positioning work.
My (working) FGRM-222s just show one endpoint, but they’re in roller blind mode.
Maybe it’s different with lamellas, do you see more than one endpoint id on your device ?
Try adding another slider item for <id>:1 or <id>:2
Or @chris, can you explain ?

Getting more desperate, some more ideas to check for:
Does changing parameter 12 make a difference ? That’s lamella turn time (if param 10 = 2)

Finally, put up a query to the FHEM forum please, or better yet, contact the FHEM module’s author.
And put a query into Fibaro forum.

I tried <id>:1 - but then it doesn’t work at all. I will check other combinations.
Now I see one endpoint, but maybe I have to exclude and include after I changed parameter to venetian blind type. But this is quite heavy now - I need to get physical access to relay, and it’s behind my chandelier.

Param 12 also works as suggested. My Lamellas fully turn in about 1.4 seconds. With original setting of 1.5s they were moving up a bit after the blinds were moved down to new position and relay tried to set previous angle (of null :frowning: ) for lamellas.

I don’t know this device, so I’m not too sure. If you want to use the Fibaro class, then you should use command=FIBARO_FGRM_222 I think. See if that works…

Hm, that doesn’t work.
2016-04-06 22:53:56.077 [WARN ] [.b.z.i.c.ZWaveConverterHandler] - NODE 111: No command class found for item = EG_Wohnen_Jalousie_links2. Class = fibaro_fgrm_222(FIBARO_FGRM_222

Here’s my node’s XML:
node111.xml (6.8 KB)

Tried MANUFACTURER_SPECIFIC, too, no luck either. That gave
2016-04-06 23:04:03.438 [WARN ] [.b.z.i.c.ZWaveConverterHandler] - NODE 111: No converter found for item = EG_Wohnen_Jalousie_links3, ignoring command.

Then again, param #3 is just about sending reports using either z-wave or Fibaro class. It doesn’t mean to control all of the device via proprietary commands.

I’ve just setup a new FGRM-222 but no luck. Changing param 10 to 2 probably won’t change the number of endpoints (there’s still only one), beause in order to re-include the device, you have to exclude or reset it first. I tried to reset the device, but then obviously param 10 gets reset, too, and still no additional endpoint shows up.

Searching for Openhab FIBARO_FGRM_222 I found:
this code here

where lines 68-84 quite unambiguous define messages for blind position and lamellas angle. This is OpenHAB code, right?
So how to make it work?

Hello, I have the shutter and lamella position working and contributed the code to @chris binding.
My items for the OH 1.8 binding looks like this one:

Rollershutter room_0_jalousie_1_actor_pos { zwave="4:command=FIBARO_FGRM_222,type=shutter"}
Rollershutter room_0_jalousie_1_actor_angle { zwave="4:command=FIBARO_FGRM_222,type=lamella"}

Cannot check the device parameters ATM.

Thanks Markus,

But I get the same warning as other Markus, when using this setup:
2016-04-08 06:57:25.718 [WARN ] [.b.z.i.c.ZWaveConverterHandler] - NODE 4: No command class found for item = Shutter_Wohnzimmer_Left_Lamellen. Class = fibaro_fgrm_222(FIBARO_FGRM_222), endpoint = 0. Ignoring command.

And nothing is working. My z-wave binding version is 1.8.1.
Is it not in main branch?

BTW it probably should be mentioned, that my FGRM-222 is shown as: Manufacturer ID = 10F, Device ID = 1000 and Device Type = 302, while recognition of command class in Z-wave binding is made using
FIBARO_FGRM_222(0x010F, 0x0301, “FIBARO_FGRM_222”, FibaroFGRM222CommandClass.class);

Mmh. I checked my installed FGRM-222 .xml to find the FIBARO_FGRM_222 command class there.
Using @maggu2810’s item definition, I can even control them using Fibar class (can’t check for lamellas to work, though, as I just have roller blinds there).
Not sure why it’s missing in the device I setup for the test (firmware version and config see .xml above), maybe a calibration run is required first.

Does invert_state work in combination with command=FIBARO_FGRM_222 ? I successfully used it on my standard zwave roller shutter item, but it seems to be ignored for the FIBARO_FGRM_222 item.
Btw, I’m on 1.8.2.

So you want to say it works for you? Why it didn’t before?

It works on an older (installed, actively used) FGRM-222 of mine to control roller blinds up/down using Fibar commands (it works in parallel to control the same blinds via standard OH zwave items).
I don’t know if it works to turn lamellas, too, because I don’t have any installed there (yet).

It still does not work to use Fibar commands to control blinds on the new FGRM-222 I’ve just setup as a test because that one does not offer the Fibar command class (it does work with standard zwave items, though). I have no explanation why the class is missing. Possibly because that device has not undergone calibration (and cannot, because physically it’s just a dummy installation without motors or blinds attached). Possibly because of something completely different like e.g. the firmware.

My device ran calibration correctly. I think this is something with firmware version

Could even be HW revisions.
Seems all older models I have (it has a blue plastic top along the line of connector screws) work fine (they offer the Fibaro class), while all newer ones (green plastic top) don’t.

Since it’s highly hardware/firmware specific to Fibaro, i think, i’m going to implement rules for venetian blinds control, independent of any HW/FW. They should even work with conventional 2-channel relay, since I have couple of those also, controlling my blinds right now (had to install as there was no other choice)
If someone already did it - wellcome to post your rules/sitemaps here.