Fibaro Single Switch 2 (FGS 213) - problem with momentary

I just added this Fibaro switch to Openhab and configured it as a momentary switch. Then I installed it into the panel, replacing the relay that originally did the job. The Fibaro works fine from an Openhab point of view.

When I use one of the physical switches though, the behaviour is strange:
Scenario 1:
turn the lights on via Openhab - works fine
switch the lights off via a physical wall switch - works fine

Scenario 2:
turn the lights on via a physical wall switch - works fine
switch the lights off via a physical wall switch - not working
switch the lights off via Openhab - works fine

Scenario 3:
turn the lights on via a physical wall switch - works fine
pushing the wall switch for about 10 seconds, then releasing it and pushing it again - then the light shuts off.

Any idea what is going on there?

Have you created any items or rules files that are associated with the switch? If so, please post for review.

Can you remove the switch from OH, to verify if OH may be the cause and test the physical ON/OFF control?

Also check the wiring of S1 and S2. If using as a regular switch nothing should be connected to S2, as this is used for advanced features such as long press.

No rules in place for the switch yet. very simple item definition, just name and channel.
S2 is not used.

Re your suggestion to remove the switch from OH: Does the physical switching work without the switch being connected into a zwave network? If so, would it be good enough just to unplug the zwave controller from the raspi to test the physical switching?

You can try it that way first and if your still having the same result I would factory reset the switch and retest.

It might be worth double checking the Advanced parameters for the unit; especially :-
28 Scenes.
10 operating mode
20 Switch type ( I see you have said it is set as momentary switch but could be worth changing this to a different type and then setting it back!)

Also check associations, OpenHab controller should be assigned to group 1

I find these settings change more reliably when using HABmin

After checking all the parameters up and down and not finding anything, I decided to implement a work-around:

  • keep the relay in place
  • install the Fibaro switch behind the relay and configure it as a toggle-switch.
    Although not “nice”, this works like a charme.
    In parallel, I opened a ticket with Fibaro - let’s see what they come up with.

I also installed a Fibaro switch to replace a timer-relay that controls the hot-water circulation pump. In this case the Fibaro is configured as a momentary switch with an AUTO/OFF timer.
Everything works fine here - you can turn the pump on via physical switches or Openhab - the timer turns it off again. No problemo.

Seems like there is really only a problem with turning the switch off via physical wall switch, if the Fibaro is configured as a momentary switch - so that it can replace a relay…