Fibaro Smart Implant and Kemo rain sensor

Hi Community

I recently added a Fibaro Smart Implant to my Openhab environment to connect a Kemo capacitive rain sensor.
Regarding the available channels I’m a little bit unsure. In my expectations I use the channel “Input 1 Alarm” to get the sensor open/closed value. But I don’t get any value there. But I can see values for “Input 1 Voltage”. While it is raining the value is 0 and if it is dry its about 10V. Thus wiring should be ok

Shouldn’t I get a value for “Input 1 Alarm” when the rain sensor changes its state?
Are there any experiences about this?

Operating mode for Input 1 is “1” (normally open)

Best regards
Levin

Update:
Voltage seems not to change if I put water on the sensor, and IN2 has about 10V too even if its nothing connected. I read somewhere that Voltag is 0 if it’s more than 10V? It seems it was a coincidence when it rained the last days and the Value changed to 0.

So maybe it is a wiring issue anyway :frowning:

Have you seen this picture:

Yes I saw this and its connected as Binary Sensor. Everything was connected by an electrician. I reviewed everything and I think the wiring should be correct. Maybe I should try IN2.
I read about defectiv “INs” in another Forum, maybe mine is defect too…

Sure you have to try the another INs.
It should work for both I think.

Also check the Kemo rain sensor. Maybe it is not closing the circuit as it should with water.

Kemo should work, I can hear the relay and see the indicator LED.
I will try IN2 as soon as possible.

IN2 doesn’t work neither. Seems I have to buy and try a new Smart Implant :frowning:

I tried with a new Smart Implant without success :-(. It has to be sensor or cabling related.
I used a multimeter to confirm that the contact circuit of Kemo is closing. So that should be ok. But there is no Voltage or something.

regarding your connectivity picture I have one difference: My Kemo contact ground is connected to the same ground as 12 DC, like the connectivity picture of fibaro
image

See Kemo manual https://asset.conrad.com/media10/add/160267/c1/-/gl/001969625ML00/bedienungsanleitung-1969625-kemo-m152k-regensensor-fertiggeraet-12-vdc.pdf

Maybe you can try like this:

kemo_fibaro

I am just guesing. Probably it can be on one power adapter. One thing is straight - both things should be power supplied.

In Fibaro’s manual there is:
Change values of parameters:
• Connected to IN1:
»Normally close: change parameter 20 to 0
»Normally open: change parameter 20 to 1
• Connected to IN2:
»Normally close: change parameter 21 to 0
»Normally open: change parameter 21 to 1

Maybe you didn’t do that?

Description of parameters is in openHAB documentation for that thing:

Actually I am out of new ideas :slight_smile:

omg it seems to work now, but I didn’t change any wiring.
I just scrolled thru the Thing Documentation you linked and read about the supported Item type for the Inputs. It seems it has to be type of “switch”. My Item was defined as “contact”.
I didn’t know that channels can be restricted to a specific type of item…

Thank you very much for your help. :+1: :clap:

Glad to hear that :slight_smile:
At least I could guide you a little bit for right direction :slight_smile:

Hi, do you have a wiring scheme for the Kemo rain sensor and the Fibaro Smart Plug?

Thx

You wrote smart plug, but I believe you mean the smart implant?
Basically it is connected as stated in the documentation. Both devices use the same Power Source and Ground (using Wago Terminals). (but I tend to disconnect the heating of the Kemo, it dries too quickly)

image