Fibaro Wall Plug FGWP102 not sending meter values

Last week I added a Fibaro Wall Plug to my openhab setup. First only the switch function works, after removing and adding it again now the power value (sensor_power) is shown. But the values for meter_watts and meter_kwh are still empty, even as the Power and energy periodic reports is set to 3600 (default). Any advice what is maybe configured wrong?

Make sure you set association groups correctly to the controller.

Think there’s a parameter where you can set the threshold for when reports are sent as well.

Other than that it should work. Next step would be to take Look at the logs.

Regards S

This is my working config:

Number FibWPlug1_E <energy> {channel="zwave:device:15ca6a108b9:node4:meter_kwh"}
Number FibWPlug1_P <energy> {channel="zwave:device:15ca6a108b9:node4:meter_watts"}

Now a small value for meter_kwh is shown


but the meter_watts is still 0.

I followed your advice and debugged, seems as the plug is reporting the meter_watts_value, too - but it is still 0.

Just to make sure: My expection for the meter_watts value would be a upcounting value of the power value, right?

Make sure you have a label defined in your items or sitemaps file:

sitemap example:

Text item=FibWPlug1_P label="Test Power WP [%.1f W]"
Text item=FibWPlug1_E label="Test Energy WP [%.2f KWh]"

Ok, you’ve got a value, did not read carefully enough, so that label is not a problem.

Next step would be to check

Yes, that is the way it works. But depending on the config settings it will most likely not detect very low values. Put a hair dryer or something like that to the plug and see what happens.

Tried it with an electric kettle, but still the reported value is 0:

I’m using the FGWP101, so am not able to help in detail.
I would check the config settings if anything is suspicious …in any case, check parameter 10, 11, 13, 14.

Maybe the config of a working 101 could help a bit:

Hm compared the values with the ones of my 102, seems to be similar, but they have a lot of different parameters:

Yeah, that is a problem when comparing older and newer versions of a device.

Did you configure your wall plug via text files? If yes I would try using HABmin and the graphical config.
I successfully solved a problem that way with my fibaro rollershutter controllers a while back …