Fibraro Switch not working

I am moving from Homeseer to OpenHab 3. I am re-using the same AEOTEC Z Stick. Scan find all ‘things’. If I select a Wallplug and create the item all works. But if I create items from a Fibaro switch ( e.g. FGS223) it SEEMS to work ok, but setting it to on/off does NOT turn on/off the ligths (Output). Manual operation of the switch DOES toggle the ligths butr does NO update the staus in OPENHAB. What am I missing?
Using Windows op UI interface

I have the same (issue). I don’t think manual switching is reported back somehow.

What do you mean by this? You link a Item of type Switch to your Wallplug Thing?

If I create an item linked to a wal-plug ‘thing’, I do see the ITEM status changing if I amnually change it from on to off. So it seems to support reporting back.
But if I create an item linked to the Fibaro switch I can change it from off to on. But the attached lights do NOT come on. If I set it to OFF again and manually press the switch, it DOES turn on thne lights but there is no feedback to OPENHAB.

I have a lot of those fibaro switches and no issues. Linking the binary switch channels works as you would expect with both local control reported and RF control working.

If the device is correctly discovered the thing should look similar to this in the UI.

and the following channels linked unless you also want power and energy.

and the lifeline set to the controller

One thing to be aware of is that these can spam your network for no good reason sending out reports every 10ms for no good reason when you think you have all reporting turned down or off. It only takes one of these behaving like that to make your network horrible.

Fibaro are aware of the issue but I doubt they will fix. By toggling parameters a few times I have found that you can get them to behave as they should.

I did check all these settings.

And created items for both switches:

I did check the Associationm Groups, These were empty. I changed them to Controller but to no avail.

The only thing I can think of now is to unjoin the switches from the network and then to include them fresh/ It is a pain, but I would start with one and she if that helps. But any other suggestion is welcome!

From that snapshot it does not look like your channels are linked to your items.

Your item needs to link to the channel and you would see a blue circle with number of items linked in the channel interface. The item would look like this with a link to the channel.

It is surprizing if the association is not set. The binding does this on initialisation so if it is not set the device might not have fully initialised.

If the items are linked to channels you could try

Alternatively could there be issues on that UI?

1 Like

Thanks for all the suggestions. The channels are created. I use the same method for all devces:

  • Create the things from the Z-Stick
  • Go to Model
  • Create Equipment from Thing
  • Go Item and test the toggle

Works for WallPlugs an dimmers. Not for the fibaro… I have two sticks. Cleared one and if I now add the Fibaro it works…

You still haven’t mentioned any actual connection between your Items and the channels, and how you made that.

They get created automatically when you create the items from things (at least it seems so from all other devices). I use Model Crets equipment from Things. That also creates items.

I think if you are inserting a stick with many devices already included it could be that it needed a bit more time to initialise all of the devices.

It takes a long time to get all of the capabilities and associations for a lot of devices and each time you restart openhab it extends the time. I can’t see any other reason why these devices would not work other than they were not fully initialised.

Hopefully you don’t have one spamming your network because that would make it even harder to do the initial discovery.

Okeydoke, then you should be able to see the “blue spot” against your zwave channels as shown in @robmac screenshot post #4, and follow that to be sure you are looking at right Items.
The blue spot was missing in the screenshot you showed us earlier i.e. no Items linked.