FIND3 install issue

Reviving an old topic here.
I just installed a completely fresh openhabian system on a Pi.
I tried installing the FIND3 server using openhabian-config and it fails at
[openHABian] Setting up FIND3 service... FAILED (adduser)

When I tried to manually start the server, I receive the following error:

panic: html/template: pattern matches no files: `templates/*`

goroutine 1 [running]:
        /usr/lib/go-1.14/src/html/template/template.go:372*Engine).LoadHTMLGlob(0x2152320, 0x7a0dfc, 0xb)
        /root/go/pkg/mod/ +0x2a8, 0x0)
        /opt/find3/server/main/src/server/server.go:48 +0x164
        /opt/find3/server/main/main.go:121 +0x840

Unfortunately, I can’t find out at what point the installation went wrong or what the next steps would be (l tried finding the actual script but failed), or I would’ve done it manually.
Since there’s an error about (adduser) , might the problem be that I don’t use “openhabian” as the default user?

Any help would be greatly appreciated.

Reinstall with debugmode=maximum in /etc/openhabian.conf enabled and eventually open a Github issue.
And please open your own thread don’t post into others’ let alone ‘solutions’.

Thanks for the quick reply and apologies for posting in the wrong thread / subforum.

With maximum debug mode I found the problem:

  • useradd --groups openhabian find3
    useradd: group ‘openhabian’ does not exist

I changed the script to use the existing “openhab” group (made more sense to me than adding an extra group) and it seemed to work nicely. I created a github issue about this: