Firefox Google links to openhab gets Corrupted Content Error

I have a weird issue when I follow a link from Google Search to Openhab community I get a protocol error using Firefox.
Some googling seems to indicate is mostly an issue with the target website.
Google search link

Firefox error:
Corrupted Content Error

The site at Toggle a Swirtch via REST API has experienced a network protocol violation that cannot be repaired.

Nope, cannot confirm, works fine. FF 61 Beta.

I had that error to a few days ago but a simple refresh of the browser fixed it everytime.
It doesn’t happen anymore.

I had to clear Cache and my site cookie data from firefox and then reset my password to get it working again…

1 Like

I’m getting this error again… what is going on here

I am also getting this error, though not limited to Google links. I seem to get it no matter how I visit the site, though intermittently.

I can open links just fine in other browsers (namely Edge), but even after clearing my cache and cookies I get the same error in Firefox.

The intermittent nature of this is what gets me. I don’t have a reliable way of triggering it, but once it happens, I cannot get it to stop.