First Alert ZCOMBO Working Instance?

Does anyone have a working instance of the First Alert Smoke and Carbon Monoxide ZCOMBO alarm (From Lowes)? I have seen some other threads around it, but have not seen a complete working instance yet.


If it’s the unit I think it is, we couldn’t get it to work properly. I forget why now, but if you’ve found the other threads, then it probably indicates the issues there.

I seem to remember the device being difficult to wake up. I have made some changes in this area recently but these aren’t in the master as yet…

Thanks for the response. I’ll keep an eye out.

Or that it never wakes up in the normal z-wave sense. It is not capable of receiving commands if I recall.

Here is the thread mentioned.

The problem had something to do with the initialization. It wouldn’t get far enough along to generate the XML file. There was a last attempted fix posted to the forum. The jar file seemed to be corrupted so I don’t know if @chris 's last attempt to fix it would work or not.

Chris - Can you reupload the jar file you uploaded here? It seems to be corrupted. I’m almost at the end of my 30-day return and want to give this one more try before I send it back to Amazon. Thanks.

It’s not possible to upload JARs here. If you email me, I’ll send you something to see if it works…

Just to tie the threads together here, @corematter has tested some changes I made to NIF processing during initialisation a few weeks back for another device, and this now works with the ZCOMBO. I’ll merge these changes into the master branch and also add a new alarm type and then I hope that this device will be supported.


1 Like

Good stuff Chris. Can you link to the PR here? I have a bunch of ZCOMBOs here to play with.


Just grab the latest snapshot off cloudbees (assuming it’s compiled last night!). One point of warning though is that the alarm it generates isn’t processing correctly- I need to fix this still (I might try and get a PR in tonight, but am travelling so will see…).


Running the latest snapshot, I excluded and included a ZCOMBO. It shows up in Habmin2 as unknown. At this point I don’t see anything different than before. What is the expectation now of how it operates?

You need to wake the device up - apparently there’s a button under the battery cover or something there-abouts?

figured it out. Do the binding sequence again without the controller in bind mode. That wakes it up and sends battery status.

2015-11-19 18:27:58 [DEBUG] [o.o.b.m.i.OpenHABEventListener:55   ] - >>>>>>>>>>message; {"topic":"smarthome/items/zwave_smoke_18_battery/state","payload":"{\"type\":\"DecimalType\",\"value\":\"100\"}","type":"ItemStateEvent"}
2015-11-19 18:27:58 [DEBUG] [o.o.b.m.i.OpenHABEventListener:74   ] - ,,,,,,,,,,,,,,,,,Event type: ItemStateEvent
2015-11-19 18:27:58 [DEBUG] [.l.i.LoggingPersistenceService:100  ] - Logged item 'zwave_smoke_18_battery' to file 'battery.log'
2015-11-19 18:27:58 [DEBUG] [o.o.b.m.i.OpenHABEventListener:98   ] - update item: zwave_smoke_18_battery
2015-11-19 18:27:58 [DEBUG] [o.o.b.m.i.OpenHABEventListener:99   ] - update object: {"type":"DecimalType","value":"100"}
2015-11-19 18:27:58 [DEBUG] [o.o.b.m.i.OpenHABEventListener:55   ] - >>>>>>>>>>message; {"topic":"smarthome/items/zwave_smoke_18_battery/statechanged","payload":"{\"type\":\"DecimalType\",\"value\":\"100\",\"oldType\":\"UnDefType\",\"oldValue\":\"NULL\"}","type":"ItemStateChangedEvent"}

That also wakes long enough to get config and write the XML. Is there anything you wish to see at this point?

Nice work Chris.

1 Like

Is there any answer to the original question ?
Does it work now ? (I’m looking to get one of those, too.)

Do you know of any alternatives ? I know there’s the Vision Security (but it can only detect CO, not smoke),
and I read about a Popp 4407 to do CO/temp/humidity, but it is not available any longer, so Popp told me.

It works, at least a test run works, so the rest is up to the sensor. It reports the event and the clear, as well as battery health when the test is run.

I did notice this later after running the test:

[ERROR] [z.i.p.c.ZWaveAlarmCommandClass] - NODE 18: Unknown Alarm Type = 13, ignoring report.

Not sure which type 13 is though.

Hmm - I thought I’d added this alarm as well, but I’ll check.


I had purchased one of the ZCOMBO devices too and was unable to get it to work last Fall. Thought I’d take another try and found this thread. Glad to see it’s working now, but not sure what I need to do to get mine working.

Downloaded the current addons snapshot and replaced my zwave binding with the new one.

Restarted openHAB and launched habmin and it looks like it did before. The Z-Stick is green and the unknown node 2 (zcombo) device is greyed out.

What do you mean when you say Do the binding sequence again without the controller in bind mode?



Perform the z-wave binding sequence as documented in the manual, but do not put the controller into include mode.

Basically, pull the battery tray out, hold the test button down while you slide the battery tray back in, and keep it held until you hear the beep. This causes it to wake up, and you should have a XML file at that point.

Thank you; that worked great!

Does someone have the .jar file that works with the zcombo device? I tried the latest daily snapshot but marked as 1.9 and zwave services don’t start in openhab 1.8 with that binding in the addons folder. Currently using the 1.8 snapshot file but just get the generic information.

Kind regards,