First Boot Failing

I’m trying to boot OpenHabian on a external drive with my RPI 3b+.
I can login with the default username and password, but then a error occurs.

I attach a picture.

Format the SD card and the hdd and try again

I’m not using a SD. Only a SSD!!!

And yes, I’ve reflashed the ssd several times.
Raspbian works with no issues!

I’d guess that it can’t connect to the Internet for some reason. What sort of network are you using, wifi or wired?

Since you can get it to work with Raspbian, try the manual openHABian instructions. I don’t know how much openHABian has been tested with SSDs, if at all. There might be something about external drives that is tripping it up.

May be an internet connection issue.
But you should be able to login and troubleshoot via ssh or local keyboard and screen.

Also try disabling IPv6, according to this suggestion

@max2 I had this issue. If you have internet execute

sudo apt-get update , then sudo aptget upgrade.

This worked for me. I may have order backwards, but it worked. There is a problem with openhabian, funny thing one of my pi’s worked the other didnt. This fixed it though.

1 Like

When i enter my password and press enter, the error occurs.
I can not execute anything.

I think I just hit ctrl c on that window and a prompt popped up. But if that does not work, and you can’t login, then there definitely is an issue.

Wait, what user? If this happens yo uhave to use the default openhabian one. The custom one from the conf file is not setup yet.

1 Like