First Run - Invalid request

I just installed openHAB2 for the first time.
Windows 10 64bit on my dedicated home media server.
The server has no monitor, keyboard nor mouse, i access it through Windows RDP on another machine.

I installed java and set the environmental variable on the server.

I got a java error “server-mode unavailable” / install java development kit.
followed other instructions in the ISSUES section of github.
uninstalled all java, only installed java dev kit 32bit.
made sure environmental variable pointed to it.

ran openHAB2 again.
no error. looks like it is running.

open chrome (tried edge too)
localhost:8080 - invalid request - (tried from server localmachine) - invalid request - (tried from server and other pcs on network)

I cannot proceed with the installation.

re-run with debugging…
says Listening for transport dt_socket at address: 5005

tried localhost:5005
the page did not load
“This page isn’t working/ didn’t send any data. ERR_EMPTY_RESPONSE” but it triggered a response in the openhab terminal window.
Debugger failed to attach: handshake failed - received >GET / HTTP/1.1< - expected >JDWP-Handshake

localhost:8080 still returns “invalid request”, but does not trigger a response in the openhab terminal window…

here is links to the logs. they are too big to copy paste
without debugging
with debugging

  • Platform information:
    • Hardware: AMD Phenom II X6 1090T
    • OS: Windows 10 64bit
    • Java Runtime Environment: jdk1.8.0_161
    • openHAB version: 2.2 and 2.3
  • Issue of the topic: please be detailed explaining your issue
  • Please post configurations (if applicable):
    • Items configuration related to the issue
    • Sitemap configuration related to the issue
    • Rules code related to the issue
    • Services configuration related to the issue
  • If logs where generated please post these here using code fences:

Looks like the address is already in use, is there another process currently running on port 8080 or 8443? Use netstat -ano to find out.

If you need to keep using that process, you can change the default openHAB port by setting the OPENHAB_HTTP_PORT and OPENHAB_HTTPS_PORT environment variables.

I have a feeling that 8080 is in use. it seems really familiar.
using netstat without openhab running it shows an active connection listening on PID 11208.
task manager shows no running process or service with PID 11208
but like I said. it sounds familiar.

so how do i change the OPENHAB_HTTP_PORT and OPENHAB_HTTPS_PORT environment variables?

utorrent webui was on port 8080.
changed utorrent webui to port 8081


1 Like