Flashing sonoff with tasmota firmware

Tags: #<Tag:0x00007f618292d9d0> #<Tag:0x00007f618292d8b8> #<Tag:0x00007f618292d7f0>

i have just flashed tasmota firmware on sonoff basic using pyflasher , and i have been informed that the firmware successfully flashed . but the device wifi network doesn’t appear at all . i tried to unplug / plug it again but the problem still exists . any help please ???

Did you restart the device after flashing?
Make sure you do not “press” the flash button so you wont be in flash mode again after restart.

You may want to check out Tasmotizer the next time you falsh a device. But NodeMCU should work, too.

You can check the serial output of the device to see if you get any errors.

read: https://tasmota.github.io/docs/Getting-Started/

1 Like

If you flashed with a file that already has your wireless credentials stored the device would connected directly to your wireless network without showING the device wifi network!

1 Like

according to the guide that i’m following , i pressed the button four times after restart .
is that wrong ?

After flashing you usually just need to power cycle the device to leave the flash mode.

Press button four times sounds like you want to reset the device or enter another mode.

i tried both , restart then don’t push the button , restart and push it .
in both , the wifi network doesn’t appear .
what’s wrong with me !

i also notice a particular behavior for the device . it continuously connects and disconnects from the computer and the led also continuously changes between fixed and flashing !

I suggest to ask the Tasmota community.
They might be more experienced than we are.

https://tasmota.github.io/docs/#join-our-community

1 Like

“Normally” the following happens after power in up:

  1. Trying to connect to a known wireless network (precompiled or saved from last )

  2. If unsuccessfull or no network credential known the WiFi manager opens a WIFI access point.

In case of 1. your device is already logged onto your network
If neither 1. nor 2. happens try reflashing or your device is either broken or not compatible.

no , i didn’t insert my wifi credentails to the flashed file

…then follow the advice from @christoph_wempe

in order to reflash i have to return to the original firmware first ? or just reflash again ?

Back to the original is not necessary, however I have read that erasing first is suggested.

ok thanks
i’ll try

Try tasmotize to flash Tasmota ,after its flashed you should get a AP with Tasmota in it

1 Like

Having read your new question in another thread, we would really appreciate to be notified if your problem is solved (You can do that by marking any reply as the solution).

1 Like

you are right and thanks for your help :heart_eyes:
my problem was solved by flashing the latest version of tasmota using tasmotizer