Frequent Warnings, where I cannot find the reason (jetty server)

Since yesterday evening I see lots of warnings in my log. All start with
2022-01-15 13:13:19.267 [WARN ] [org.eclipse.jetty.server.HttpChannel] - /rest/persistence/items/Error:%20Unexpected%20%22]%22%20at%20character%2031
java.lang.IllegalArgumentException: Illegal character in path at index 75: http://192.168

I have no clue, where to look for the reason for this. At the time, when the entries first popped up, I did nothing specific to the openhab installation.

I have already cleared / deleted the cache and the tmp directory. That was the closed hint from @rlkoshak I could find here.

I am runing the package version from OH3.2 on a PI4 with Buster.

It looks like something is making requests to openHAB with invalid URLs.

It shows the url (though I’m assuming you truncated it). The character it doesn’t like in the url is the 75th one. That should give you a clue.

I exactly understood the problem as you described. However, I am not aware that I do anything with an url similar to this.

The complete url reads:

I have tried to access …/rest/persistence/items , this results in “{“name”:“Error”,“datapoints”:“0”,“data”:[]}”

So still no idea, where that could come from.

That part suggests it might have to do with a charting or ‘analyze’ function being displayed

currently there are app. 800 items in my set up…

As I wrote before, there are a lot of error messages in one entry, truncated at a certain point with the hint, that there would be 45 more lines. These all look like:

at org.apache.cxf.transport.servlet.BaseUrlHelper.getBaseURL( ~[?:?]
at org.eclipse.jetty.servlet.ServletHandler.doScope( ~[?:?]

Would there be anything where I can look closer, to identity the root cause? Would it help to paste the complete entry?

Like @rlkoshak says, “something” is sending a broken REST request to openHAB. Cannot say what,most likely a GUI, perhaps a rule, or something else.

would retrieve persistence data for a named Item xxxx.
Here it’s tried to use "Error:%20Unexpected%20..." as an Item name, and blown up because : is illegal character in Item names.

It looks like the mystery requester has run into it’s own problem (an unexpected ] at char 31 of something else, maybe?), and is sending us an error message instead of an Item name.

To work out the mystery requester, you’ll have to think about who/what would request persistence data via REST. I would guess some charting widget.

1 Like

what is using REST inside OpenHAB? My current understanding is, that REST is used, when I want to access something within OpenHAB from the outside. That is currently not used here. Or are there internal processes working with REST? Ie.: when I want to achieve xxx, OH normally uses REST requests…

All the UIs use the REST API all the time. It’s how your browser communicates with your openHAB server.

Thanks for the help, I think we can close it.After @rlkoshak last comment I played around with my brwoswer and had the suspicion, that it could be in connection with some widgets, I have integrated in the last couple of days. Having a closer look, I did find that in two of them I was referring to an item, which does not exist:

    actionAnalyzerItems: =[props.item +"_Total"]

when looking at the code
“actionAnalyzerItems”: “\u003d[props.item +”_EnergyUsage"]"
that could match the “Unexpected%20%22]%22” from the log.

After I corrected the entry, the error messages did not occur again.

The bad news is, that I saved the “wrong” widget file (uicomponents_ui_widget.json) before the change and reinstalled it after the positive result. The error did not reoccur, even with the widget including the missing item :frowning: