Fresh installation and no webinterface

Just testing with Ubuntu 20.04 Lts.

Did a fresh installation of stable openhab2 2.5

Webserver on Port 8080 is running, but only get not found message of jetty

In log openhab i can see found multiple interfaces and all IPv4 interfaces are ignored, so no dashboards coming up

Allready tried to bind to a special ip with /etc/default/openhab.conf, but errors are still the same

Just found a solution for myself:
Had to configure the IP and network in /var/lib/openhab2/config/org/exclipe/smarthome/network.config by hand with a texteditor.

For me this is solved, but after or within a fresh installation, there must be a question oder an automatic configuration of Network there!

It would be good to share what exactly you added to your openhab_userdata/config/org/eclipse/smarthome/network.config.

My file only has this inside, so I would have no clue how to apply your solution."true"""

Also this behavior is very odd, I have setup up openHAB on Debian, Ubuntu, Arch, Docker and more.
I never experienced this behavior, I know the openHAB initial startup can take a while so there is no web-interface, but this can be seen in the logs.

What exactly is your setup? You just state 20.04 Lts
Is there anything special about this setup? 2 LAN Interfaces or something?

Sorry I didn’t directly:

I have got three interfaces:
Vpn (tun0) with Class c subnet (10.10.2.x)
External lan to router (eth0) with class c subnet 192.168.1.x
Internal lan (eth1) with class b subnet 10.10.1.x)

I got error messages for all up Adressen given to this three devices and for local host

I searched in forum and found solution to set ip and network via paperUI, but paperUI not startable on this system.

So I searched on other system with openhab running and found entry


In this file. So i added and openhab started.

If I look in documentation normally openhab should have been started for all ips, until this is set via paperUI

1 Like