Fresh openhab2 install doesn't allow any file creation for items, or sitemaps

I’m a total openHAB beginner and followed the online tutorial for installation of openHAB 2 on a Raspi 3. All worked well and the tutorial worked great with first bindings, things, items, etc… in Paper UI.

When I got to the part where manual editing is required, I understood that config files need to be created in /etc/openhab2 which is set to be write-only by the user openhab:openhab

Now what? When I login to the Raspi, I’m user pi. I cannot su to openhab.

Searching this forum and the net, I learn that openHABian comes with a config utility to fix permissions. What does that do? I used the apt-get method to install openHAB. Any advice?



The easiest way to get started is to install openhabian on a sd card.

This one openhabian-pi-raspios32-v1.6.1b.img.xz

OpenHAB 3 has just been released if you want to try that.

If you installed through openHABian there is a samba share you can access from another machine that has the right permissions.

On the machine itself, you use sudo to execute a command as root and sudio -u openhab to execute a command as the user openhab.

Fix permissions (which is also part of openhab-cli) will make sure that everything is set so that the openhab user can edit them.

Thank you for the quick replies. I installed Samba as suggested and that works well.

On the machine I now use sudo -u openhab for quick editing, thanks for pointing that out.

Somehow I was expecting to be able to have a writable directory to do my stuff but never mind, I’m learning…