FRITZ!DECT 200 remains in Status INITIALIZING -> changed to binding reacts not on fixed status

Hello all,

after spending a weekend without testing OH2 and updating to the latest Cloudbees build #161 the Outlet-function of the linked channels stopped working with this message in the log:

Not delegating command 'ON' for item 'K_Schrank' to handler for channel 'avmfritz:FRITZ_DECT_200:192_168_178_1:087610216689:outlet', because thing is not initialized (must be in status ONLINE or OFFLINE).

Where there some relevant changes between last week where it definitely works and now?


I didn’t analyze it any closer, but it sounds similar to me as Something that needs to be looked at, I will add a link on that issue.

Btw, it is interesting that you say that it worked in the past, because I just remembered that there is an open issue in the tracker about the FRITZ!DECT 200:

Thanks for your fast feedback @Kai,

maybe it depends of the very awesome progress of OH2 in the last months, so i could only confirm what worked last week. For the next test as Beta-Tester i’ll try to keep the nightly-bilding-version of cloudbees in mind for further reports :wink:

FRITZ!DECT 200 worked for me last week, i ordered 2 more devices and with [quote=“Heiko_Fanieng, post:1, topic:8148”]
Cloudbees build #161
[/quote] all devices stopped working in the switching part today.

Maybe tomorrow i’ll focus on Philips Hue and/or Z-Wave - i don’t have the intention as beta-tester to expect that everything works as expected :slightly_smiling:


Thanks for your patience as a beta tester.
I just analyzed it: The change was indeed due to a recent change in ESH, which now does not automatically set a Thing to ONLINE anymore, but leaves it to the binding to decide whether it should be ONLINE or OFFLINE.
Good news is: I have adapted the AVM binding and successfully tested it.

Great News :smile: What is the delay between your changes in ESH the nightly builds at cloudless? I don’t want to continue testing if the update isn’t available for me …

Thanks to you and all other maintainer for your great job with OH2!

The fix was on the binding, not in ESH.
It is contained in this openhab2-addons build, which triggered this distro build, which hence should contain the change.

Not shure i’ve got the right version of the AVM-binding ([147:org.openhab.binding.avmfritz:]) with fresh installed snapshot, but i got this error in the log when trying to switch the device:

17:41:57.443 [ERROR] [ome.core.thing.internal.ThingManager] - Exception occured while calling handler: java.lang.NullPointerException
java.util.concurrent.ExecutionException: java.lang.NullPointerException
	at java.util.concurrent.FutureTask.get([:1.8.0_72]
	at org.eclipse.smarthome.core.common.SafeMethodCaller.callAsynchronous([89:org.eclipse.smarthome.core:]
	at org.eclipse.smarthome.core.thing.internal.ThingManager.receiveCommand([95:org.eclipse.smarthome.core.thing:]
	at org.eclipse.smarthome.core.common.SafeMethodCaller$[89:org.eclipse.smarthome.core:]
	at java.util.concurrent.ThreadPoolExecutor.runWorker([:1.8.0_72]
	at java.util.concurrent.ThreadPoolExecutor$[:1.8.0_72]
Caused by: java.lang.NullPointerException
	at org.openhab.binding.avmfritz.handler.DeviceHandler.handleCommand([147:org.openhab.binding.avmfritz:]
	at org.eclipse.smarthome.core.thing.internal.ThingManager$[95:org.eclipse.smarthome.core.thing:]
	at org.eclipse.smarthome.core.thing.internal.ThingManager$[95:org.eclipse.smarthome.core.thing:]
	... 5 more

Well, this looks very much like the issue mentioned above, which is still open. I only fixed the “remains in INITIALIZING” bug so far…

I could confirm that FRITZ!DECT 200 devices are now schon as ONLINE in Paper UI as mentioned in the configuration above.

It could be helpful for beta-Tester to know on what functions it make sense to test it or not :wink:

Is it now a part of the binding i have to wait for a fix of robbyb67, who is present in the Issue-Tracker at GitHub and is not present in the forum here?

Yeah, sorry, I would have loved to fix the NPE last night as well, but I couldn’t test, because my openHAB instance is running on the computer that is plugged into my FRITZ!DECT 200 - so testing it is a bad idea :wink:

It could be helpful for beta-Tester to know on what functions it make sense to test it or not :wink:

It makes sense to test everything for which there isn’t yet an open issue in the issue tracker!


Hello all,
i am a newbie with openhab. I installed the latest Cloudbees build #214.
i try to get my Fritz!Dect running, but it still remains in status INITIALIZING.

How can I configure the access to my fritz!box (Username and password)?

What about the bridge in the configuration?

Thank you for your help!

Is there nobody working on this issue? I am really waiting for this binding working well! Thanks very much for your help!

Just fyi: I submitted a pull request late last night that fixes the problem.

So it’s up to @Kai now I guess :slight_smile:


Merged, many thanks, @janKG!

You’re welcome, thanks for the fast merge!