Fritzbox TR064 Binding not finding Fritzbox

Hey guys,
I would like to use my FritzBox 6590 Cable with FritzOS 7.0 to get presence detection.
But somehow the addon is not working for me.
I configured a user “openhab” and entered the ip and user/password in the binding config but the fritzbox thing doesnt show up in the inbox. Same if I click on “Search for Things” and on the Binding - nothing happens.

If I try to reinstall the binding hundreds of errors like the following happen:

  2018-09-30 11:08:26.192 [INFO ] [org.openhab.binding.fritzboxtr064   ] - FrameworkEvent INFO - org.openhab.binding.fritzboxtr064 Exception in opening zip file: /var/lib/openhab2/cache/org.eclipse.osgi/222/0/.cp/lib/httpclient-win-4.4.1.jar of stack trace...
Caused by: /var/lib/openhab2/cache/org.eclipse.osgi/222/0/.cp/lib/httpclient-win-4.4.1.jar (No such file or directory)

full openhab.log:

This happens with other files too, like:

  • httpcore-4.4.1.jar
  • commons-codec-1.9.jar
  • commons-logging-1.2.jar
  • fluent-hc-4.4.1.jar

Whats the problem here?
I already tried to delete everything in /var/lib/openhab2/cache/* and /var/lib/openhab2/tmp/*, and also tried the same in a docker container running openhab instead of Ubuntu.

Hopefully someone may help me, the temperatures are getting lower and I don’t want to set my heating manually :sweat_smile:

Hi Max,

I just ran into the same problem. Looking at the directory structure given in the error message, all the permissions were set to “openhab:MyName” (Ubuntu).

After executing

“chown -R openhab:openhab /var/lib/openhab2”,

at least the installation of the binding worked for me. Not sure if this helps for you.



Hi, did you follow the prerequisites?

Best jackzone

Hi jackzone,

the binding now works for me. The problem was about the permission setup in ubuntu as suspected.

As a sinde note: Maybe it’s a quirk in the restore shell script, actually after restoring things and items via restore-script, all those files had the “wrong” permissions again.