Hey there, since I upgraded to the new fritzbox TR064 binding with subdevices openhab fails to login to the fritzbox.

Openhab log Error:

2022-10-14 17:41:32.995 [INFO ] [ab.event.ThingStatusInfoChangedEvent] - Thing 'tr064:fritzbox:c38aa26288' changed from OFFLINE (COMMUNICATION_ERROR): 
com.sun.xml.messaging.saaj.SOAPExceptionImpl: Unable to create envelope from given source:  to OFFLINE 
(COMMUNICATION_ERROR): HTTP-Response-Code 500 (Internal Server Error), SOAP-Fault: 401 ()

Fritzbox Systemlog (Ereignisse) Error:

Anmeldung einer app mit unbekanntem anmeldenamen von gescheitert.

(Login from app with unknown login-name failed)

My setup:

  1. Fritzbox 6660 cable, FRITZ!OS: 07.29
  2. Raspberry Pi 4 Model B Rev 1.1
  3. Raspbian GNU/Linux 10 (buster), Linux 5.10.63
  4. openHAB 3.3.0 - Release Build

TR064 Binding config:

UID: tr064:fritzbox:c38aa26288
label: FRITZ!Box
thingTypeUID: tr064:fritzbox
  phonebookInterval: 600
  refresh: 60
  password: *****
  user: openhab

I also test with newly created user.
Also with the original one, with or without “dsl-config”.
Always same error.
Login through the UI works with all of them.

Anybody seen that?

I have a different FritzBox, but the FritzOS version and OH version are the same here. No issues with the connection.

Did you check the user credentials in the FritzBox (System/Fritz!Box users)? In my case the upper 3 boxes of 5 are ticked (#2 and #3 become active when #1 is ticked and can’t be unticked separately).

1 Like

Hi @stefan.oh , thanks for you feedback!
I checked the config, in my config also the upper 3 boxes were checked (guess that was the default). Then I also enabled nr 4, but both did not work.

So, except the NAS access, is that equal to your side?

By the way, I have a Unitymedia branded version with some limits.

That’s good to know. I don’t think that the branding will affect login procedures but it may be worthwhile to check other forums for the error message you see.

The settings are the same, except for the NAS access:

The error message clearly indicates an authentication issue on the FrotzBox side, so either the user or the passwords you configured is not correct. The username “openhab” should not be an issue, but the password may contain characters that are not transpoerted correctly or are coded in a way that the FritzBox does not recognize them. Although you can log in with the same user/pw interactively on the login prompt of the FritzBox, the password or parts of it may be encoded in some way between OH and the FritzBox.
To check that, you may change the password in the FritzBox, check with a interactive login on the FritzBox itself and then configure the same password in OH (restart OH afterwards to be sure).
Ensure the password only contains characters from “A” to “Z”, “a” to “z” and numbers, no “special characters” like “&”, “?” etc.
If the issue is eliminated that way, you can test out special characters one by one if you see a real need to use those.

1 Like

Thanks again! The password contained only one camel case word and a number without any special characters. I also had tested the default user and password (no special chars) same problem. All working fine when logging in via UI.
I contacted now Fritzbox support and they just answered and got the support-logfiles from me.
I will update you with the results.
Schönen Sonntag noch :slight_smile:

1 Like

I am having the same issue. I just upgraded to openHAB 3.3 from 2.5 and the new TR-064 Binding binding comes back with all thought of errors. Last one I got is:

"com.sun.xml.messaging.saaj.SOAPExceptionImpl: Unable to create envelope from given source:"
UID: tr064:fritzbox:Fritzbox7490
label: FRITZ!Box 7490
thingTypeUID: tr064:fritzbox
  phonebookInterval: 600
  refresh: 60
  password: G******6
  user: openhab

I am running a Fritz!Box 7490 with 7.29 Firmware.
I did try out the Fritzbox auto generated user account (since dsl-config is not valid anymore to my understanding and has been replaced by this auto generated user), which did also not work.
Did anyone solve this kind of issue?

Hi @gloeckner_ronny , so that’s really surprising. I just did not care anymore about that issue after FritzBox support informed me, that this is a client (openhab) issue. And they weren’t able to explain what this weird error message means (that is shown in the FritzBox System log!).

Now, where you asked for a solution I checked the TR064 things status, AND - it’s online! Fritzbox System log confirms that the login was successful.
But, I wasn’t actively working on that issue, just did the openhab upgrade, nothing else.

BTW: can you check your fritzbox System log and confirm that you see the same error there that I showed above? You find it in the menu at “System” → “Ereignisse /Events”.