Fronius binding: Currently generated power never 0?!

Tags: #<Tag:0x00007fe735bc6eb0> #<Tag:0x00007fe735bc6de8> #<Tag:0x00007fe735bc6d20>

Hi all,

some days ago I added my Fronius photovoltaic inverter to OpenHAB and created several items which I added to my sitemap. The data compared to the Fronius app looks good, except the currently created power from my photovoltaic. I thought it’s the “AC Powery” channel, but even at night, whenno power is generated, this value shows a W value.

So I think, this is not the value I want to see. Could you please help me, which one is the currently generated power channel? DC current would look good, except that the measurement is Ampere and not Watt.

But what I see in the Fronius app is Watt or KWh.

Could you please help me? The official docu (https://www.openhab.org/addons/bindings/fronius/) is, what a pitty, for me not detailed enough at that point.

Thanks and kind regards,

Dirk

This is what I get as channels for my fronius Symo (at night):

AC power              -NaN W    trending_up  // power generated right now
Day Energy            3.87 kWh  trending_up  // sum of energy production (today)
Total Energy        29.431 MWh  trending_up  // sum of energy production (total)
Year Energy          0.044 MWh  trending_up  // sum of energy production (this year)
AC frequency          -NaN Hz   trending_up  // frequency of energy to grid power
AC current            -NaN A    trending_up  // current at AC (i.e. 230V) 
DC current            0.00 A    trending_up  // current at DC (i.e. solar panels)
AC voltage            -NaN V    trending_up  // voltage at AC (i.e. 230V) 
DC voltage             4.4 V    trending_up  // voltage at DC (i.e. solar panels)
Grid Power         1396.97 W    trending_up  // power consumption from grid
Load Power        -1396.97 W    trending_up  // power delivery to grid
Battery Power         0.00 W                 // when installed, power consumption from battery

As you can see, there are some NaN values, this is because the Symo Inverter is in standby (it’s dark)

Hello Udo,
thanks for your reply.

I have the following:
AC power 21.80 W
Day Energy 7.71 kWh
Year Energy 0.057 MWh
Total Energy 9.657 MWh
Grid Power 396.61 W
Load Power -396.61 W

All look like the data from the Fronius App, except the AC power.
The data above is the latest I had writing this response. As you see: Grid Power and Load Power are equal, so there cannot be any currently generated power if I need all of the power from the grid.

My default.items entry looks like:

Number House_Photovoltaik_Current_Produced_Power “Erzeugt [%.2f W]” { channel=“fronius:powerinverter:704aaf29:inverterdatachannelpac” }

This is how my default.sitemaps entry looks like:

    Text label="Photovoltaik" icon="solarplant"
    {
        Text item=House_Photovoltaik_Current_Produced_Power
        Text item=House_Photovoltaik_Grid_Power
        Text item=House_Photovoltaik_Current_Needed_Power
        Text item=House_Photovoltaik_Today_Power
        Text item=House_Photovoltaik_Current_Year_Power
        Text item=House_Photovoltaik_Total_Power
    }

Could this perhaps be caused by caching or something like that, so that it doesn’t “forget” the currently shown entry? Or is the number items type perhaps not nullable and therefore it cannot be displayed and always shows the last not null value?

I would appreciate if you could post your AC power items and sitemaps entry. Perhaps I use a wrong way of including the item?!

Thanks and kind regards,

Dirk

fronius.things

Bridge fronius:bridge:bridge "Fronius Bridge" @ "PV" [ hostname="pv.udo.lokal" ] {
    Thing powerinverter fronius "Symo 10" @ "PV" [  ]
}

As I did not define any channel, all channels are default channels.

fronius.items

Number   Symo10_Inverterdatachannelpac         "AC power"        {channel="fronius:powerinverter:bridge:fronius:inverterdatachannelpac"}
Number   Symo10_Inverterdatachanneldayenergy   "Day Energy"      {channel="fronius:powerinverter:bridge:fronius:inverterdatachanneldayenergy"}
Number   Symo10_Inverterdatachanneltotal       "Total Energy"    {channel="fronius:powerinverter:bridge:fronius:inverterdatachanneltotal"}
Number   Symo10_Inverterdatachannelyear        "Year Energy"     {channel="fronius:powerinverter:bridge:fronius:inverterdatachannelyear"}
Number   Symo10_Inverterdatachannelfac         "AC frequency"    {channel="fronius:powerinverter:bridge:fronius:inverterdatachannelfac"}
Number   Symo10_Inverterdatachanneliac         "AC current"      {channel="fronius:powerinverter:bridge:fronius:inverterdatachanneliac"}
Number   Symo10_Inverterdatachannelidc         "DC current"      {channel="fronius:powerinverter:bridge:fronius:inverterdatachannelidc"}
Number   Symo10_Inverterdatachanneluac         "AC voltage"      {channel="fronius:powerinverter:bridge:fronius:inverterdatachanneluac"}
Number   Symo10_Inverterdatachanneludc         "DC voltage"      {channel="fronius:powerinverter:bridge:fronius:inverterdatachanneludc"}
Number   Symo10_Powerflowchannelpgrid          "Grid Power"      {channel="fronius:powerinverter:bridge:fronius:powerflowchannelpgrid"}
Number   Symo10_Powerflowchannelpload          "Load Power"      {channel="fronius:powerinverter:bridge:fronius:powerflowchannelpload"}
Number   Symo10_Powerflowchannelpakku          "Battery Power"   {channel="fronius:powerinverter:bridge:fronius:powerflowchannelpakku"}

I’m on openHAB2.5.0 #1499, I,m not aware of changes, but just to be sure…

Maybe the Binding is very smart and does only show channels supported by the device, on the other hand, I guess you can see the data in the fronius web interface.

Good Morning Udo,

thanks a lot! I added Fronius via the “Things” mask in Paper Ui. So I’m not aware if this differs from your manual .things file config. Nevertheless I’ll try your version, too.

The hint to check the Fronius web interface what they exactly show. Perhaps the app is not detailed enough.

Thanks and kind regards,

Dirk

In fact, I did it the same way, and the result is the same. It’s easier to post a text file :wink:

Hello Udo,

you are right. :wink:

Strange thing: I was not yet able to try your config but wanted to do so over the week-end. Today I re-configured my raspberry pi (which runs openHAB) to use a static ip and a hostname within my network.

After adapting the openHAB app to that new ip, the photovoltaic information for the currently generated power shows “-”. I’ll keep an eye on it if this changes after power was generated tomorrow and then stucks on this last value.

Kind regards and enjoy your week-end,

Dirk

I also have this issue; during the whole night when the AC power is 0, the last read value stays in openhab.
Does this have to do with the fact that in the resulting json from the API call, when there is no production, there is no entry for the produced power?

I also have the issue that actually something like the last positive value stays during the night (like 35 watts) and never drops to zero.

Additonally it would be perfect is the other data from the solar.api from the smart meter could be added as channels.

@trokohl @gerritbeine

http://iphere/solar_api/v1/GetMeterRealtimeData.cgi?Scope=Device&DeviceId=0&DataCollection=MeterRealtimeData

{
   "Body" : {
      "Data" : {
         "Current_AC_Phase_1" : 0.83099999999999996,
         "Current_AC_Phase_2" : 0.76500000000000001,
         "Current_AC_Phase_3" : 1.4059999999999999,
         "Details" : {
            "Manufacturer" : "Fronius",
            "Model" : "Smart Meter 63A",
            "Serial" : "xxxxx"
         },
         "Enable" : 1,
         "EnergyReactive_VArAC_Sum_Consumed" : 684550,
         "EnergyReactive_VArAC_Sum_Produced" : 74290820,
         "EnergyReal_WAC_Minus_Absolute" : 7626094,
         "EnergyReal_WAC_Plus_Absolute" : 17280611,
         "EnergyReal_WAC_Sum_Consumed" : 17280611,
         "EnergyReal_WAC_Sum_Produced" : 7626094,
         "Frequency_Phase_Average" : 50,
         "Meter_Location_Current" : 0,
         "PowerApparent_S_Phase_1" : 194.86949999999999,
         "PowerApparent_S_Phase_2" : 179.23950000000002,
         "PowerApparent_S_Phase_3" : 330.97239999999999,
         "PowerApparent_S_Sum" : 613,
         "PowerFactor_Phase_1" : 0.48999999999999999,
         "PowerFactor_Phase_2" : 0.28999999999999998,
         "PowerFactor_Phase_3" : 0.69999999999999996,
         "PowerFactor_Sum" : 0.55000000000000004,
         "PowerReactive_Q_Phase_1" : -143.59,
         "PowerReactive_Q_Phase_2" : -164.31,
         "PowerReactive_Q_Phase_3" : -204.63,
         "PowerReactive_Q_Sum" : -512.52999999999997,
         "PowerReal_P_Phase_1" : 82.400000000000006,
         "PowerReal_P_Phase_2" : 50.420000000000002,
         "PowerReal_P_Phase_3" : 204.84999999999999,
         "PowerReal_P_Sum" : 337.67000000000002,
         "TimeStamp" : 1580943274,
         "Visible" : 1,
         "Voltage_AC_PhaseToPhase_12" : 406,
         "Voltage_AC_PhaseToPhase_23" : 406.80000000000001,
         "Voltage_AC_PhaseToPhase_31" : 406.89999999999998,
         "Voltage_AC_Phase_1" : 234.5,
         "Voltage_AC_Phase_2" : 234.30000000000001,
         "Voltage_AC_Phase_3" : 235.40000000000001
      }
   },
   "Head" : {
      "RequestArguments" : {
         "DeviceClass" : "Meter",
         "DeviceId" : "0",
         "Scope" : "Device"
      },
      "Status" : {
         "Code" : 0,
         "Reason" : "",
         "UserMessage" : ""
      },
      "Timestamp" : "2020-02-05T23:54:35+01:00"
   }
}

//can be deleted

I’ve just submitted a PR (and it got merged to OH3) that fixed this issue. I’ve also submitted it to 2.5.x hopefully to be merged soon too.