Fronius binding Inverter ERROR COMM

Hi all, today i setup openhab on Rasperry pi at my friends place. He is using a Fronius Symo Gen24 inverter for his solar system. Entering the local IP in the browser its also possible to read all the relevant values (Solar power, battery SOP, house consumption, etc) via the front end.
Using the fronius binding and the local IP of the inverter also the bridge thing showed online. However the powerinverter thing went from “CONFIG” to “ERROR: COMM”. The log message was Invalid JSON data received. It tried several device ids (0, 1, 2) in the thing config, no change.

Can someone help us to get the values in openhab?

Thank you alot :slight_smile:

Login to your GEN24 locally and check in “Communication” … “Solar Api” if the Api is enabled.

1 Like

Thank you for the hint. We found the settings->communication menu, however its locked by a password and my friend is missing the password. To make sure we are talking about the same, here is a screenshot of the menu


Can you confirm that this is the right one? Than he will check for the password

Yes:

fron1

Default password is 12345678 , but this usually gets changed during setup of the solar system. What you need is the Customer password (Kundenpasswort), which should have been provided by your vendor. There is also a Technician password which mostly you won’t get from your vendor.

2 Likes