Frontail log not running get a connection refused

Rpi4 running openhabian (hasslefree) from UBS drive (SSD).

Ever since I updated my Rpi4 with latest firmware (released) to boot from USB device and installed openhabian 2.5.5 and newer, I have had major issues starting the tailog everytime I restart openhab… Normally it can take 2-4 minutes before it suddenly start to work.
Now I just updated to 2.5.7-1, and I can enter the tail log at all… Still getting connection refused in my browser. Openhab is running fine, and the logfile is updating just fine. Just the tailog messing up…

Can anyone advice what to do?
I was suppose to troubbleshooting something, which is rather pointless without the tailog running. I use it all the time when I change or do changes to my system.

I enter http://IP:9001 to enter the tailog. It has worked on all my openhab setups… But this one is really becoming a problem… I updated openhab aprox 20 minutes ago… And I still cant enter tailog :weary:

On my main system I run openhab 2.5.6 on a Rpi3 also booting from USB (SSD). And this setup has no issues with tailog running, and never has had any issues. So I suspect it may be a Rpi4 issue, or something went totally wrong somewhere during the first setup.

Hmm I just ran the menu 21 from openhabian-config (install the frontail log. This is what happened, and now its running again:

2020-07-27_19:56:48_CEST [openHABian] Beginning setup of the openHAB Log Viewer (frontail)...
2020-07-27_19:56:48_CEST [openHABian] Updating openHAB Log Viewer (frontail)...
$ npm update --force -g frontail
npm WARN using --force I sure hope you know what you are doing.

   │                                                                │
   │      New patch version of npm available! 6.14.5 → 6.14.7       │
   │   Changelog:   │
   │               Run npm install -g npm to update!                │
   │                                                                │

2020-07-27_19:56:54_CEST [openHABian] Configuring openHAB Log Viewer (frontail)... OK
2020-07-27_19:56:54_CEST [openHABian] Setting up openHAB Log Viewer (frontail) service...
$ systemctl enable frontail.service

$ systemctl restart frontail.service
2020-07-27_19:56:54_CEST [openHABian] Adding an openHAB dashboard tile for 'frontail'... Replacing... OK

I havnt tried restarting openhab, yet. Will do that in a few hours.

Just restarted openhab, and the issue is back :frowning:

Just made a fresh install of openhab2 (version 2.5.7-1) And the very same issue again…
Next I will try a fresh install on a SD card insted of USB boot from SSD.

I´m not sure what to say… But this is rather annoying…
I just finished spending 40 minutes on installing a fresh openhab 2.5.7-1 on a SD card… And guess what… I got the very same issue again. Frontail logviewer is not running…

This time I noticed, at the end of the openhab installation, it installs the frontail logviewer, it also start the service, and a few second after, it stops the service and never starts it again…
That explain howcome it doesnt work.

using openhabian-config to “install” the logviewer will make it work, but not without issues. After restarting openhab, it still wont be running.

I´m not sure whom to tag on this one, but there are some issues on the image, thats for sure…
At least I had no better things to do the last 4-5 hours :face_with_symbols_over_mouth:

Btw… This is suppose to be “stable” version…Hmm!

openHABian is a completely different “product” from openHAB. They don’t have a concept of “stable” versus “testing” versus “snapshot”. With openHABian your only option is basically snapshot. The most recent stuff checked in is what you get.

There is a PR to maybe change this but I’ve not followed it to know where it’s gone.

openHAB 2.5.x is very stable. It’s not changed since 2.5.0 was released. The 2.5.x bindings are less so, releasing updates every month or so. openHABian has never been stable. It’s always been the latest and greatest as your only option. And openHABian automatically upgrades to the latest when you run it.

As for who to tag, probably the best is to file an issue on the openHABian repo.

You choose whether to install openHAB Stable, Testing, or Snapshot within openHABian through openhabian-config. I believe it defaults to stable.

What is the output of the command

sudo journalctl -xu frontail 

Yes openHABian has this concept now. This was introduced several weeks ago.
So there now is the more or less same concept of “stable” as opposed to “master” which is latest.
Just that updates inside the branch you are on happen automatically on start of openhabian-config.
New code changes are only being applied to master, and changes are “forwarded” in batches after a reasonable testing period.
You get messages and a changelog displayed on (first) start of openhabian-config when there was an update.


Hmm… Im not sure I understand. On the download page, getting the image for Rpi, you have to choose from stable or snapshot. (I always choose stable). And it will install openhabian on the rpi.

Openhab 2.5.0 was indeed very stable… But ever since I started to update my systems, I have had issues which I honestly dont understand, since all newer releases should only contain changes to bindings.

In another thread I promised to do some doc for doing backups of openhab.
My main idea was to use my main production system (Rpi3B+) to backup and restore onto my test setup (Rpi4). But in order to do this, I have to make sure each systems are running the exact same version. Unfortunatly I keep on getting issues on my Rpi4 system every time I install a new fresh setup, (probably due to issues with the Rpi image as mentioned in the other thread), so I simply cant make it.
When the image is not stable, ts like restoring a backup to an OS which you know have issues… Makes it rather pointless.
My main system runs fine though, probably because it has been a very long time since it was rebuild using an image.

openHABian != openHAB

openHABian is not openHAB

openHABian is a completely different set of software from openHAB.

openHAB and openHABian are different products with different purposes.

openHAB = A Java program with add-ons that allow a user to interact with home automation technologies
openHABian = A collection of bash scripts that installs and configures openHAB and a number of other third party applications like Frontail in a standardized way.

I don’t know how many other different ways I can say this.

Yes, indeed, openHABian lets you choose which openHAB version you want to install. That has nothing to do with the version of openHABian itself. openHAB release may not change for six months. openHABian might change every week (I’m making up the time). They are independent projects with independent release cycles.

For the record, the openHAB Cloud Server, iOS App, Android app, and Docker image are all also independent projects with their own independent release cycle.

Are you updating openHABian? I think it automatically updates to the latest when you run openhabian-config. Are you updating the system? That will update everything else (Mosquitto, Frontail, etc) on the machine. A change doesn’t have to be in openHAB core to cause you problems. The Amazon Echo Control binding is a perfect example. Amazon changed something on their end and suddenly a memory leak appears in openHAB. Someone who hasn’t changed a thing since OH 2.3 recently ran into this problem. They didn’t change anything and yet stuff changes outside out control.

Well, they will never be the same if your RPi3 remains unupgraded. And, as discussed above, this means the whole system, not just openHAB. Once they are running the same version of everything, than when you start openhabian-config, when it asks whether to continue or skip “openHABian Update Available”, choose “Skip.” Never run an upgrade until you can do it on both systems at the same time.

If you run upgrades or choose to upgrade openHABian than no, the system isn’t stable. You are changing things every time.

[18:02:52] openhabian@openhab:~$ sudo journalctl -xu frontail
-- Logs begin at Mon 2020-07-27 23:47:03 CEST, end at Tue 2020-07-28 18:03:04 CEST. --
Jul 28 00:24:08 openhab systemd[1]: Started Frontail openHAB instance, reachable at http://openhab:9001.
-- Subject: A start job for unit frontail.service has finished successfully
-- Defined-By: systemd
-- Support:
-- A start job for unit frontail.service has finished successfully.
-- The job identifier is 1910.
Jul 28 00:24:08 openhab systemd[1]: Stopping Frontail openHAB instance, reachable at http://openhab:9001..
-- Subject: A stop job for unit frontail.service has begun execution
-- Defined-By: systemd
-- Support:
-- A stop job for unit frontail.service has begun execution.
-- The job identifier is 1968.
Jul 28 00:24:08 openhab systemd[1]: frontail.service: Main process exited, code=killed, status=15/TERM
-- Subject: Unit process exited
-- Defined-By: systemd
-- Support:
-- An ExecStart= process belonging to unit frontail.service has exited.
-- The process' exit code is 'killed' and its exit status is 15.
Jul 28 00:24:08 openhab systemd[1]: frontail.service: Succeeded.
-- Subject: Unit succeeded
-- Defined-By: systemd
-- Support:
-- The unit frontail.service has successfully entered the 'dead' state.
Jul 28 00:24:08 openhab systemd[1]: Stopped Frontail openHAB instance, reachable at http://openhab:9001.
-- Subject: A stop job for unit frontail.service has finished
-- Defined-By: systemd
-- Support:
-- A stop job for unit frontail.service has finished.
-- The job identifier is 1968 and the job result is done.
lines 1-39/39 (END)

I know very little about Linux, but to me this seems like the service has stopped.

I just had this discussion with Markus as well…
Its very confusing stating openHABian is not openHAB, when the document says:

Notice the title, “… openHAB setup
Mind you, this is the doc for setting up openhabian hassle-free. Just as I did a few times.

Next, which makes it even more confusing… This is the dashboard:

Notice the bottom it says, “openHAB 2.5.7 Release Build

Stating this is openHABian, and therefore not openHAB related (or at least not the same) really doesnt make sense, except for those who know alot deeper (having a high technical background).
I know, (due to my knowlegde) openhabian is openHAB installed on rasbian allright. But its still openHAB.
I know (due to my knowlegde) Frontail is an external service.

What I fail to understand is WHY you and others are trying to throw this issue to anything else than openHAB. And specially why it matters?
Where are users who run into this issue suppose to report the issue then… At Frontail? Frontail will claim its a setup issue of openHAB (openHABian in this case), and then the user is back to here, except noone seems to care because its an openHABian…

Someone should deal with it. But I in this particular situation, there are no where to report it… I cant even file an issue if I listen to what you say, cause its not a openHAB issue…

No other ways needed. you just said it. openHABian is scripts that installs openHAB as well as other stuff.

Unfortunatly, specially regarding Frontail, these scripts (or whatever) also installs a link (icon) on the dashboard to something called “OPENHAB LOGVIEWER”. Clicking on this icon will lead to a blank pages saying “Connection refused”.
Due to the above showing, it would lead most user to assume, something went wrong when installing openHAB, wether or not its openhabian/scripts etc… The dashboard says openHAB. The Doc´s says openHAB… How come openHAB team/forum/you/Markus/whatever then try to reject it?

I tried both upgrading and fresh installation. Untill yesterday my Rpi4 was running 2.5.6. It was original installed with the openhabian image a coupple of weeks ago. When still having issues with Frontail, I upgraded to 2.5.7, which ofcouse didnt change anything, (ofcouse, since its the same image with the same issue).

But this is not really the point… The point is:
There are issues with the installation when installing openHAB using the openhabian hassle-free setup.
The ackward situation going on here now is, that you among others reject the issue saying its not an openHAB issue but an openhabian issue (or Frontail issue or… anything else than openHAB issue!).

And thats probably the cause of this issue… Seems like a script fault somewhere during the installation. Maybe someone forgot to restart Frontail… I dont know…

But where to report and who is going to fix it, when openHAB reject this because its not an openHAB issue?

As I said - It doesnt make sense when you reject this issue saying its a external service.

My Rpi3 is original openhabian hassle-free installed very long time ago, and has been upgraded periodic during the time. Atm its at openHAB 2.5.6 and has no issue with Frontail, because that was not an issue when it was original installed long time ago.

The public available Rpi image for the Hassle-free openHAB setup has issues.
If reporting this particular issue is beeing offtopic in the openHAB forum, then tell me where it suits?

Same problem here, but sadly no solution from my side ;-(

Link to the german forum regarding this topic:

Many thanks for any support.

Best regards

The last change that was done in the frontail.service file was on 17. June 2020.
( row PartOf= openhab2.service was added ).
This means whenever openhab2.service is ended for whatever reason also frontail service will end.
Looking into the journalctl output it is stated

ExecStart= process belonging to unit frontail.service has exited

which would mean that frontail is stopped because of openhab2.service is not started or stopped again.
In case my interpretation is not correct please correct me.

My question: you wrote that openhab itself is running ok. was that also the case for the time the output was provided ?

Yes… openhab has been running since yesterday… But not Frontail.

According to the logfile frontail was started and stopped immediately again.
For testing purposes you could put the PartOf row into a comment and revert back after doing the test.
The drawback will be that frontail will not be stopped once openhab.service will be stopped or ends for whatever reason.

What part of

openHABian aims to provide a self-configuring Linux system setup specific to the needs of every openHAB user. To that end, the project provides two things:

  • Complete SD-card images pre-configured with openHAB and many other openHAB- and Hardware-specific preparations for the Raspberry Pi
  • The openHABian Configuration Tool to set up and configure openHAB and many related things on any Debian/Ubuntu based system

makes you think that openHABian == openHAB. It says it right there. It’s an SD card image with openHAB preconfigured and a configuration tool to set up and configure openHAB. “openHAB” is the object of both of those sentences. It’s the thing that openHABian is doing stuff to. “openHAB” is not the subject of the sentences.

Obviously, if you have a better way to say it to make it more clear we welcome contributions.

Because it is vital to understand the difference to:

  • understand who to ask for help
  • understand where to file issues

Start with openHABian to see if it’s a problem with the installation scripts. If not then yes, Frontail is the place to file the issue. We didn’t write Frontail. We are not maintaining Frontail. We can do nothing to fix problems in Frontail that are not caused by how openHABian installs it.

No one anywhere said that we don’t care because it’s openHABian. But when people bitch that openHAB isn’t stable because openHABian has broken something, or worse, that openHAB is unstable because something else that openHABian installed is broken like Frontail, it’s not a fair attack. It has nothing to do with openHAB itself. In the latter case it has nothing to do with openHABian.

File the issue here:

Just like if you have a problem with the Android app, you don’t file the issue in openhab-core or openhab-addons, you file it on the Android app’s repo:

Shall we remove the link and make it harder for users to use to avoid this confusion?

And we reject it because you have to know what it is to know where to file the issue!

File an issue on the openHABian project.

I never said it wasn’t an issue. I’m just trying to get you to file the freaking issue in the right repo.

If it’s not our software what would you have us do? If the problem is in fact caused by something in the openHABian scripts than yes, we will fix it. If it’s something caused be a change in the upstream Frontail there is nothing we can do. It’s not our software. It’s not our project. It’s not our code.

It’s not off topic for the forum, as evidenced by the fact that there are lots of openHABian threads and this one hasn’t been removed. But saying “openHAB is unstable because Frontail won’t start” is:

  • factually incorrect
  • potentially hides the problem from the right people who can help with the problem
  • hides where to file an issue if there is a bug

Let’s assume there is a problem with the openHABian scripts. Should you file an issue at openhab-core? No! Those are not the developers who maintain openHABian and that isn’t where the openHABian code resides? openhab-addons? openhab-android? openhab-cloud? No! Those are all separate projects and the openHABian code doesn’t reside there. You need to file the issue in the openHABian repo.


I actually never said openhab is unstable. I said all the way, that frontail is either not running or I cant connect untill a few minutes after openhab has restarted.
From the very beginning I wrote:

Later I wrote:


This last part is ofcouse a “huge” mistake by me… I should have been 110% precise writing:
I just finished spending 40 minutes on installing a fresh openhabian 2.5.7-1 on a SD card

My bad! :unamused:

I have tried to explain, from a user point of view, why a user would react to this as beeing an openHAB issue. You dont agree, which to me seem more like beeing a reason of your knowledge, rather than to read what I´m trying to explain.
I´m a simple user, I can tell the symptoms of an issue. I can not tell the cause or anything else than what I see, which in this particular situation is openHAB written everywhere. And yet you expect me to know, this is not an openHAB issue.
Heck, if it wasn´t for the monitor I have connected to the Rpi as well as having just a tiny little knowlegde, I would never have known, that the Frontail service is beeing stopped during installation. And I would have no idea wether this is a, Frontail, openHAB or openhabian issue…
How am I suppose to know?

Ok this happend to me now too. openhab openhabian linux whatever it is you need to spend some time investigating what is wrong. I am thankfull for all the contributors and effort that has been put in before me. Reading some of the comments here took you longer to write and me longer to read than it took me to figure out where the issue could be.

to get it running again in the mean time just run

sudo systemctl start frontail.service

@mstormi Can you please fix this issue and thanks in advance