Frontail log viewer no longer scrolling

Tags: #<Tag:0x00007f6182c81708>
  • Platform information:
    • Raspberry Pi 3
    • OS: Openhabian v 1.4.1
  • Issue of the topic:

HI I first installed openhabian about 4 weeks ago with no issues. After a lot of experimenting and learning I finally decided to start setting it up proper so started with a fresh install.
Again openhabian is running fine with no issues Except for one thing.

While viewing the logs via http://myip:9001 the page no longer automatically scrolls down! which is a pain when trying to debug!

So far I have tried…
-Another Fresh install x2 (one of which is on a brand new sd card)
-I have tried different web browsers
-2 days of googling.

POSSIBLE CAUSE?
The only thing I can find that has changed since my first install and my most recent is that the application Frontail recently updated to version 4.4.0 from version from version 4.3.3

However as a noob, despite googling I am unable to find away to downgrade frontail to a previous version to test my idea.

Any help would be great
Mark

Have you checked the wiki for any issues regarding this?

Never tried it, so no guarantee, but you might be able to downgrade using the Karaf console.

I have gone through the issues on github for openhabian and frontail and can find nothing that relates to this. I do not know the Karaf console however if it is possible to downgrade I imagine it should be possible through ssh with putty.
I can confirm the version using frontail --version but beyond that I am stuck.

I’ve been reading, and like you, haven’t found much regarding the issue. Have you tried using some of the tools in > sudo openhabian-config like system tweaks, updates, etc… maybe that will fix the issue.

Yep I have gone through all the upgrades and tweaks but none seem to fix the issue. The more I think about it the more I think it must be related to the recent ( 15 days ago ) update of frontail.
As you suggested I have looked into the Karaf console and have accessed it via ssh, I am just going through the bundle commands on the wiki to see if I can downgrade or uninstall current version and re install an older version.
I feel there will be a lot more googling required before I work that one out though so if anyone out there has a better idea I am all ears :slight_smile:

What version of OH are you running? My current server is using 2.3 and looking at frontail it shows version 4.2.2, even after using openhabian to update.

I am running the latest openhabian image which is using V2.3 I believe, and when I check it shows my frontail version as 4.4.0 So I am assuming you have not updated your install lately but as I have done a fresh install it automatically downloads the latest versions.

Before posting above I used openhabian-config to update packages and upgrade system. Not sure what the difference is??

@illnesse does some nice custom work with BasicUI, Frontail, etc… he might know a good starting point for solving the issue.

SUCCESS!
After Logging in via ssh you can run this command to view the availible frontail versions
npm view frontail versions
This showed me the previous version was available. I then uninstalled frontail and removed the package using
sudo npm -g uninstall frontail --save
Finally I was able to install version 4.3.3 using
sudo npm -g install frontail@4.3.3

Now my log view is auto scrolling again :slight_smile:

This also in my eyes confirms there is an issue with frontaill 4.4.0 on openhabian so as more people do fresh installs it may come up on google a little more often.

As previously said " I am a noob" so not sure if there is somewhere I should report this issue to?

@H102 thanks for bashing this one out with me :+1:

I also encountered this issue in frontail in the latest verion 4.5.1. Reverting to an older version screwed up the highlighting.
I now used as a workaround an auto-scroll extension (Simple auto-scroll) in google-chrome. Works like a charm :slight_smile:

Has anyone come up with a solution that works with the latest frontail versions (and does not require extensions)?

Looks like the author may have fixed this…

i now have the same problem with
openhabian 2.4 (stable)
Frontail 4.8.0

Chrome Browser

Same problem here with Frontail 4.9.0… Works fine in chrome but within the Android Openhab application, no auto-scrolling, no scrollbars… only scrolls to the bottom of the file after I do a blank search (ie. enter the search field and press Enter)… Suggestions?

Hello together,

this is not a bug in OpenHab. I found an issue at frontail javascript.

You can found this line here:
/usr/local/lib/node_modules/frontail/web/assets/app.js

Let me know if this fix the issue for you.