Frontail Log Viewer no longer working?

  • Platform information: Pi3
    Release = Raspbian GNU/Linux 8 (jessie)
    Kernel = Linux 4.9.35-v7+
    Platform = Raspberry Pi 3 Model B Rev 1.2
    • openHAB version:2.2.0-1
  • Issue of the topic: please be detailed explaining your issue
    Frontail and the Logviewer were working fine till 01-11-2018 and then just stopped and I can’t tell what’s wrong. I’ve tried reinstalling it tried accessing the logs through the karaf console but the logs just don’t update.
    I’ve tried the Manual/Fresh Setup option on Configuration Tool but nothing seems to help.

What about tail?
Do your openHAB logs update at all?

Tail doesn’t show anything just a blank cmd line.
The logs show the same info as the Log Viewer.
Last event was on 2018-01-11

Have you tried this?

sudo mv /var/lib/openhab2/etc/org.ops4j.pax.logging.cfg /var/lib/openhab2/etc/org.ops4j.pax.logging.cfg.old
sudo mv /var/lib/openhab2/etc/org.ops4j.pax.logging.cfg.dpkg-dist /var/lib/openhab2/etc/org.ops4j.pax.logging.cfg

sudo systemctl restart openhab2.service

When you update to 2.2 the files for logtail are slightly different

1 Like

Matt’s correct. You should have answered ‘yes’ to the request to replace files, when performing the update. Matt’s answer will fix that problem, and re-instate your logs.

Thanks Matt and Nigel
That took care of it.
I’m always afraid to tell an installation to replace files when I’m not sure what to do and it’s giving me an option like it will work either way.

I did the same, it took me a while to figure it out.


1 Like